
mMass 5.5.0 User’s Guide
by Martin Strohalm

 © 2005-2013

  





Contents
1. ..................................................................................................................Preface 5

1.1. ............................................................................................................................Motivation 5
1.2. .................................................................................................................................Authors 5
1.3. ..............................................................................................................Publications to Cite 6
1.4. ........................................................................................................................Technicalities 6
1.5. .................................................................................................Typographical Conventions 6

2. ....................................................................................................Version History  7

3. ...............................................................................................................License 13

4. ..........................................................................................................Installation 14
4.1. ..........................................................................................................................Mac OS X 14
4.2. ......................................................................................................................MS Windows 14
4.3. ..................................................................................................................................Linux 15
4.4. .........................................................................................................Running from Source 15

5. .....................................................................................................User Interface 17
5.1. ............................................................................................................Application Layout 17
5.2. .........................................................................................................................Main Menu 17
5.3. ...............................................................................................................................Toolbar 21
5.4. ................................................................................................................Documents Panel 22
5.5. ................................................................................................................Spectrum Viewer 25
5.6. .....................................................................................................................Peaklist Panel 31

6. ...............................................................................................Document Basics 33
6.1. .............................................................................................................Supported Formats 33
6.2. .................................................................................................................Open Document 33
6.3. ................................................................................................................Blank Document 34
6.4. ..................................................................................................................Save Document 34
6.5. .................................................................................................................................Export 35
6.6. ....................................................................................................................Print Spectrum 35
6.7. ...................................................................................................................Document Info 36
6.8. ..................................................................................................................Analysis Report 37

7. ..................................................................................................Data Processing 39
7.1. ................................................................................................................Math Operations 39
7.2. ....................................................................................................................................Crop 41
7.3. ............................................................................................................Baseline Correction 41
7.4. ..........................................................................................................................Smoothing 42
7.5. .......................................................................................................................Peak Picking 43
7.6. ........................................................................................................................Deisotoping 44
7.7. ....................................................................................................................Deconvolution 46
7.8. ................................................................................................................Batch Processing 46
7.9. ...............................................................................................................................Utilities 47

8. ..........................................................................................................Calibration 48

9. ................................................................................Periodic Table of Elements 50

10. ..................................................................................................Mass Calculator 51
10.1. ..................................................................................................................Formula Syntax 51
10.2. .........................................................................................................Compound Summary 51
10.3. ............................................................................................................................Ion Series 51
10.4. ..................................................................................................................Isotopic Pattern 52



11. .................................................................................................Mass to Formula 54

12. ................................................................................................Mass Defect Plot 56

13. ..................................................................................................Sequence Tools 57
13.1. ..................................................................................................................Sequence Editor 57
13.2. .....................................................................................................................Modifications 59
13.3. ....................................................................................................................Protein Digest 60
13.4. .......................................................................................................Peptide Fragmentation 61
13.5. ....................................................................................................................Data Matching 62
13.6. .......................................................................................................................Mass Search 64

14. ..........................................................................................................Mass Filter 65

15. ............................................................................................Compounds Search 67

16. ................................................................................................Peak Differences 70

17. ...........................................................................................Compare Peak Lists 71

18. ...........................................................................................Spectrum Generator 72

19. .......................................................................................................Envelope Fit 73

20. ....................................................................................................Mascot Search 75

21. ................................................................................................ProFound Search 77

22. ..................................................................................Protein Prospector Search 78

23. .............................................................................................................Libraries 79
23.1. ........................................................................................................................Compounds 79
23.2. .....................................................................................................................Modifications 80
23.3. ..........................................................................................................................Monomers 82
23.4. .............................................................................................................................Enzymes 83
23.5. ..............................................................................................................Reference Masses 84
23.6. ...................................................................................................................Mascot Servers 85
23.7. ................................................................................................................................Presets 86



1. Preface
mMass is the fruit of years of study and development.  While I’ve put a lot of energy into making this 
program as stable and reliable as possible, mMass comes with no warranty of any kind. You are however 
welcome to read the code, modify it and send me any suggestions or patches. mMass development still 
continues, so any ideas,  function requests or bug reports are more than welcome. Feel free to contact me 
through the mMass’s web page http://www.mmass.org or join the forum at http://forum.mmass.org.

1.1. Motivation

While tools for the automated analysis of MS and LC-MS/ MS data are continuously improving, it is still 
often the case that at the end of an experiment, the mass spectrometrists will spend time carefully 
examining individual spectra. Current software support is mostly provided only by the instrument 
vendors, and the available software tools are often instrument-dependent. Such software can only be used 
to analyze data from a specific instrument, and this causes serious problems for laboratories that use more 
than one instrument.  This tight software-instrument relationship also causes problems for laboratories that 
do not possess their own instruments, and have to obtain mass spectra from other, collaborating, 
laboratories. To provide a solution to these limitations I have started to develop mMass - open source 
multi-platform tool for precise mass spectrometric data analysis and interpretation.

1.2. Authors

 Martin Strohalm: Laboratory of Molecular Structure Characterization
  Institute of Microbiology, Prague
  Academy of Sciences of the Czech Republic
  http://ms.biomed.cas.cz
  http://www.mmass.org

I wish to express my thanks to all the people involved in the excellent Python language, wxPython and 
NumPy libraries, and namely to the people helping me to make mMass still better:

 Daniel Kavan:  C programing
  Laboratory of Molecular Structure Characterization
  Institute of Microbiology, Prague
  Academy of Sciences of the Czech Republic
  http://ms.biomed.cas.cz

 Timo Niedermeyer: Custom-type sequence handling and fragmentation design
  Institute of Pharmaceutical Biology,
  EMA-University Greifswald, Germany
  Cyano Biotech GmbH, Germany

 Sebastian Gibb:  OpenSUSE packages
  Universität Leipzig, Germany

 Filippo Rusconi:  Debian packages
  Laboratoire de Biophysique - INSERM - CNRS - MNHN, France
  http://www.massxpert.org

 Petr Novák:
 Petr Man:
 Michael Volný: Mass spectrometry consultations
  Laboratory of Molecular Structure Characterization
  Institute of Microbiology, Prague
  Academy of Sciences of the Czech Republic
  http://ms.biomed.cas.cz
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1.3. Publications to Cite

• Niedermeyer THJ and Strohalm M
mMass as a Software Tool for the Annotation of Cyclic Peptide Tandem Mass Spectra 
PLoS ONE 7 (9), e44913 (2012)
DOI:10.1371/journal.pone.0044913

• Strohalm M, Kavan D, Novák P, Volný M, Havlíček V: 
mMass 3: A Cross-Platform Software Environment for Precise Analysis of Mass Spectrometric Data. 
Anal Chem 82 (11), 4648-51 (2010)
DOI:10.1021/ac100818g

• Strohalm M, Hassman M, Košata B, Kodíček M
mMass Data Miner: an Open Source Alternative for Mass Spectrometric Data Analysis.
Rapid Commun Mass Spec 22 (6), 905-908 (2008)
DOI:10.1002/rcm.3444

1.4. Technicalities

At the very beginning, mMass started as a simple PHP-based tool to compare peak differences within 
mass spectrum. Fortunately, PHP wasn’t powerful enough for calculations and I stated to learn Python... 

Current version of mMass is written mostly in Python programing language (http://www.python.org) and 
uses wxPython libraries (http://www.wxpython.org) for graphical user interface (GUI) and NumPy 
module (http://www.numpy.org) for faster computing of mathematical tasks. 

Since resolution of modern mass spectrometers grows up,  resulting data sets become very large. Even 
Python powered by NumPy is not powerful enough for some calculations, therefore a piece of code 
written in C has been added into mMass to speed-up some processing functions.

1.5. Typographical Conventions

Following typographical conventions are used throughout this document:

Names of mMass’s components and modules, names of dialog values etc.

Menu items and buttons.

Terminal commands, scripts and other pieces of code.

Advanced tips and hints.

Important notes and warnings.
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2. Version History
Version 5.5.0 (released July 1, 2013)

 Peak list can now be exported into ASCII with column headers.
 Mass to Formula tool is now able to calculate negative compositions (element losses).
 Form parameters updated in Protein Prospector tools.
 Mass to Formula tool crashed when no composition was found.
 Correct scan number is now parsed from mzML format.

Version 5.4.1 (released Dec 25, 2012)

 Internal server has been disabled for OS X.
 An issue with crashing plot canvas.
 An issue with crashing Envelope Fit tool.

Version 5.4.0 (released Nov 18, 2012)

 Multiple documents overlay in Mass Defect Plot panel.
 On Linux, system user’s folder is now used for configs and presets.
 Incorrect handling of C-terminal modification in Peptide Fragmentation panel.
 Incorrect calculation of some mass defects.
 An issue with peak picking crashing on some documents.
 An issue with mzML files with incorrect base peak intensity.
 An issue with mzML files with unspecified retention time units.
 Incorrect zooming style in Scan Selection dialog.
 Updated link to ChemSpider from Mass to Formula panel.
 Updated link to Human Metabolom Database from Mass to Formula tool.

Version 5.3.0 (released Aug 27, 2012)

 Mass Defect Plot to clusterize peaks based on their mass defect.
 Swap Data function is now available in the Batch Processing panel.
 Line style can be set for profile mass spectra.
 Open multiple documents via command line.
 An issue with negatively charged ions matching.

Version 5.2.0 (released Jul 1, 2012)

 New spectrum canvas view option to allow ranges outside current documents boundaries.
 File association now works on all platforms via listening on port 65456.
 More detailed Spectrum Ruler info for charge and neutral mass.
 In some cases, document selection in batch processing was unpredictable.

Version 5.1.0 (released May 17, 2012)

 Mass to Formula tool now compares theoretical isotopic pattern with acquired data.
 Isotopic pattern can be modeled using either symmetrical or asymmetrical peak shapes.
 Artificial spectra can be modeled using either symmetrical or asymmetrical peak shapes.
 Compare Peak Lists tool now shows additional table with combined peak list.
 Compare Peak Lists tool now enables intensity ratio threshold for highlighting peaks.
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 Unmatched peaks can now be removed from Peak Differences tool table.
 Neutral mass can be calculated and shown by Spectrum Ruler tool.
 Peak list generated by Isotopic Pattern tool is calculated from final envelope.
 Baseline shift removed from normalization.
 Preview in Math Operations tool did not work correctly.
 An issue with re-creating configuration files.
 Peak list updating in Match panel plot.

Version 5.0.1 (released Mar 28, 2012)

 Molecular formula of the peptide is shown in custom-type Sequence Editor.
 Sequence Search tool did not work.
 Sequence info did not update correctly while switching sequences.
 Applying processing tools with no document selected may cause application to crash.
 An issue with mzML files with different data array bits.

Version 5.0.0 (released Mar 2, 2012)

 Mass to Formula tool to generate molecular formula from given m/z value.
 Batch Processing tool to apply multiple processing steps to multiple documents at once.
 Minor axis ticks can be shown in spectrum canvas.
 Peak area can be calculated and shown by Spectrum Ruler tool.
 Protein charge state can be calculated and shown by Spectrum Ruler tool.
 Overlay function added to Math Operations panel.
 Combine all, Average all and Overlay all functions added to Math Operations panel.
 Photoshop-like method to see/enable just one document while hiding others.
 Sequence modifications can be applied specifically to N or C terminus.
 New view option to show/hide labels' Group name.
 Part of the mMass's processing core is now written in C.
 Faster Math Operations.
 Faster loading of single-scan documents from mzML, mzXML and mzData.
 Information shown by Spectrum Ruler tool can be set via application menu View.
 Drawing of individual peaks in pattern simulator can be disabled to speed up calculation.
 Multiple files selection in Open dialog.
 Application crashed when peaks were labeled with Sequence panel opened.

Version 4.0.0 (released Dec 2, 2011)

 New Sequence Editor to define custom peptide sequence with non-standard amino acids.
 Peptide sequence can be set as linear or cyclic.
 N-terminal modifications can be saved in presets.
 Internal monomer library with more that 500 building blocks from NORINE database.
 Monomer Library Editor for user-defined monomers and corresponding neutral losses.
 Improved Peptide Fragmentation tool with more fragmentation pathways.
 Gaussian smoothing filter.
 Overall matched intensity is calculated and shown in Match panel and Sample Report.
 Envelope Fit tool to determine heavy atoms exchange (e.g for HDX experiments).
 Monoisotopic mass determination for large proteins with isotopically resolved envelope.
 Charge state is shown in the bottom bar for Measure Distance tool and current difference.
 Save All feature to save all opened documents at once.
 Current document’s path is shown in Document Info panel.
 Charge column is shown for annotations and sequence matches in Sample Report.
 User’s Guide PDF is accessible via application menu Help.
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 Definition of the z-series ions according to Mascot.
 Polished icons to better fit into OS X Lion.
 An issue with mzData time parameter.

Version 3.12.1 (released Aug 28, 2011)

 Application sometimes crashed while closing last document.
 Some peaks were skipped when peak picking height was set to 100%.
 Calibration curve sometimes did not fit well.

Version 3.12.0 (released Jul 14, 2011)

 Deconvolution tool to generate deconvoluted peak list from peaks with assigned charge.
 New document can be created directly from clipboard data.
 Different application layouts are available via Window menu.
 Group name parameter can be specified for any peak via Peak Editor.
 Group name column can be shown in Peaklist Panel.
 For Label Envelope tool, intensity can be calculated as envelope max, sum or average.
 Faster calculation of complex isotopic distributions.
 Spectrum Generator tool is using native peak’s FWHM value to generate spectra.
 Unified toolbar for all platforms.
 Isotopic envelope was not calculated correctly for single-isotope compounds.
 Peak list was not updated correctly after applying math functions.
 Some toolbars were not drawn correctly in floating panels.
 Peak lists concatenation (A+B) did not work correctly.

Version 3.11.0 (released May 10, 2011)

 Simple Spectrum Generator tool for artificial mass spectra generation.
 Cancel button for long-running tasks.
 All the peak picking tools are using baseline according to Baseline Correction panel.
 Live threshold line preview is shown for Peak Picking tool according to current settings.
 Label Envelope tool to label isotopes or envelope centroid or to “measure” peak charge.
 Isotope mass shift correction parameter in Deisotoping panel.
 Support for MGF (Mascot Generic Format) data format.
 User annotations and sequence matches can be shown as “labels” in Spectrum Viewer.
 Peaklist Panel columns can be enabled or disabled.
 A.i. value can be shown in Peaklist Panel.
 Neutral mass is calculated and can be shown in Peaklist Panel.
 Left-click+Alt/Ctrl on a document title in Documents Panel hides other documents.
 Scale y-axis simply by mouse scroll with the cursor positioned in the y-axis area.
 Sequence accession number can be specified in Sequence Editor.
 Direct links to protein databases are available in Report via protein accession numbers.
 H3PO4 neutral loss added to Sequence Fragmentation panel.
 Semi-specific mass search in Sequence Panel can be enabled.
 Various speed improvements for high-resolution data.
 Application closing is much faster.
 Parameters of manual peak picking tools were moved to corresponding processing panels.
 Documents loading queue.
 Sequence Editor popup menu now behaves correctly.
 Specifity filter in Sequence Modifications panel correctly handles terminal amino acids.
 Metadata (e.g. operator, contact) are correctly loaded from mzData, mzXML and mzML.
 Resolved an issue causing axis labels overlapping.
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Version 3.10.0 (released Feb 23, 2011)

 Mass Filter tool to annotate or remove contaminant masses.
 Set Mass Range tool to specify current mass range in Spectrum Panel.
 Font and line scaling can be specified in Export Spectrum Image tool.
 Peak list filter can be specified in Match panel and protein identification tools.
 IDs for PubChem Compounds and NORINE peptide database are recognized in Report.
 New items in Peptide Fragmentation panel.
 Data normalization tool moved to Processing Panel.
 All annotations and sequence matches are removed when processing tools are applied.

Version 3.9.0 (released Dec 15, 2010)

 Compare Peak Lists tool to compare peak lists between multiple documents.
 Simple math functions are now available to add, subtract and multiply spectra.
 Peptides, fragments or compounds lists can be filtered to show matched/unmatched items.
 Sequences from digest, fragments or peptide search lists can be copied into clipboard.
 Duplicate copy of selected document can be make via pop-up menu in Documents Panel.
 Distance measurement tool shows current distance in both m/z and ppm (bottom bar only).
 Multiple documents can be opened at once using Open dialog.
 Correct drawing of spectra with no continuous baseline (typically for SIM experiments).
 FWHM and resolution columns in a peak list can now be copied into clipboard as well.
 Option to enable/disable notation marks now works correctly.

Version 3.8.0 (released Aug 20, 2010)

 TIC and BPC chromatograms are now available in scan selection dialog.
 Support for mzML data format.
 Spectrum intensity offset (visual only) can be set either manually or using new mouse tool. 
 Intensity bar is now available in Spectrum Panel.
 Height of position bar and intensity bar can now be set in Canvas Properties.
 New view option to show/hide spectrum data points.
 Peak width is assigned automatically when overlaying theoretical isotopic patterns.
 Incorrect charge calculation in Deisotoping module.
 Incorrect file extension for files converted by CompassXport.

Version 3.7.0 (released Jul 19, 2010)

 Simplified interface for Protein Prospector tools MS-Fit and MS-Tag.
 FWHM and resolution is now calculated for each peak and shown in Peaklist Panel.
 Global modifications can now be stored as presets.
 Spectrum polarity can now be set in Document Info panel.
 Application crashed when "None" document was sent into Calibration Panel.
 Some of the potential peaks were skipped in Shoulder Peaks Removal algorithm.
 Data matching for negative spectra was not possible with Ignore charge option unchecked.

Version 3.6.0 (released Jul 5, 2010)

 Match Summary is now available for each data matching.
 Remove shoulder peaks option is now available for FTMS data peak-picking.
 All annotations and sequence matches can now be removed at once from Document panel.
 Compounds and reference masses can now be imported using corresponding library editor.
 Spectrum flipping is now accessible from the View menu.
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 Faster peak-picking, especially when Adaptive threshold option is used.
 Loading of some mzXML files with parameter "compressionType=none" was not possible.
 Application crashed on a single right-click in Isotopic pattern panel.

Version 3.5.0 (released Jun 4, 2010)

 Possibility to vertically flip spectra in Spectrum Viewer.
 -H2O can now be searched in Compounds Search tool.
 Normalized view did not worked for centroid spectra.

Version 3.4.0 (released May 12, 2010)

 Radical ions can now be calculated in Mass Calculator and Compounds Search tools.
 Single-point linear calibration has been enabled.
 Calibration curve is now shown in the calibration error plot.
 Current peak list is now shown as a background in error plots (calibration, data matching).
 New view option to enable/disable normalized view of opened documents.
 New view option to enable/disable notation marks.
 All annotations and matches can now be highlighted by selecting a document root.
 Theoretical and matched sequence coverage is now shown in Protein Digest tool.
 Final composition of ion is validated in ion series calculations.
 Automatic checking for available updates has been added.
 Application preferences for updates and CompassXport utility has been added.
 Mass Calculator - calculation of ions with negative agent charge.
 Mass Calculator - pattern modeling with complex charging agent.
 Normalization now includes baseline shift.

Version 3.3.0 (released Apr 9, 2010)

 Periodic Table of the elements has been added.
 Bruker's raw data are imported using CompassXport tool (MSW only).
 Small fixes in manual peak picking.
 Dropping documents to mMass caused the source window to freeze until loading finished.
 Mass Search tool - Enzyme endings selection did not worked.
 Mass Search tool - Max charge has been replaced by Charge.
 Mass Search tool - better filtering.

Version 3.2.0 (released Mar 14, 2010)

 Isotopic Pattern panel is now collapsable.
 Hidden modifications can now be enabled in Mascot Search interface.
 Modified documents are marked by asterisk.
 Relative intensity for annotations and matches is now calculated on-the-fly.

Version 3.1.0 (released Mar 3, 2010)

 Lipid database (by LIPID MAPS Consortium) has been added to Compounds Search tool.
 ProFound Search interface has been implemented.
 Sequences can now be imported form mMass’s and FASTA files.
 Manually labeled peak can now be automatically set as monoisotopic.
 Specific cursor images for spectrum tools has been added.
 Scan list buffer is now used to speed-up loading of multi-scan documents.
 Multiple fixes in Mascot Search interface.
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 Peak-picking algorithm has been improved.
 More "Pythonic" syntax in the mspy module.
 Spectrum tools are now accessible from the main menu as well.

Version 3.0.0 (released Feb 1, 2010)

Complete mMass redesign - new user interface, new features and new source code architecture.

mMass User’s Guide

© 2005–2013 Martin Strohalm  Page 12



3. License
This program and its documentation are Copyright © 2005-2012 by Martin Strohalm.

This program, along with all associated documentation, is free software; you can redistribute it and/or 
modify it under the terms of the GNU General Public License as published by the Free Software 
Foundation.  See the file LICENSE.TXT for details (and make sure that you have entirely read and 
understood it!)

Please note in particular that, if you use this program, or ANY part of it - even a single line of code - in 
another application, the resulting application becomes also GPL. In other words, GPL is a 
"contaminating" license. 

If you do not understand any portion of this notice, please seek appropriate professional legal advice.  If 
you do not or - for any reason - you can not accept ALL of these conditions, then you must not use nor 
distribute this program.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without 
even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  
See the GNU General Public License (http://www.gnu.org).

The origin of this software must not be misrepresented; you must not claim that you wrote the original 
software. Altered source versions must be clearly marked as such, and must not be misrepresented as 
being the original software. This notice must not be removed or altered from any source distribution.
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4. Installation
4.1. Mac OS X

As usually, there is no special installation procedure for Mac OS X. mMass is available as a regular disk 
image containing the “mMass.app” application. This is a standalone package containing all the necessary 
modules and libraries. To install mMass just open the disk image and drag the mMass.app to your 
application folder.  After first run mMass creates the specific folder “~/Library/Application Support/
mMass/” to store all your presets and objects libraries. Current version of mMass was successfully tested 
on the Intel based computers with Mac OS X 10.5 and 10.6.

mMass’s installation disk image for Mac OS X.

4.2. MS Windows

In most cases, installation on MS Windows is very easy.  mMass is available as regular ZIP archive 
containing the “mMass”  application folder. There are no installation steps needed to run mMass under 
MS Windows. This means that you can run the program directly after unpacking downloaded archive. 
Simply run the “mmass.exe”. Current version of mMass was successfully tested on XP SP3,  Vista and 
Windows7.

Please note that you must have the privileges for writing to the “mMass” folder, otherwise you will 
not be able to store any program presets such as startup defaults, modifications etc.

For older versions of MS Windows, mMass sometimes doesn’t want to start up showing the following 
message instead: The application failed to start because the application configuration is incorrect. 
Reinstalling the application may fix this problem.  In such a case you’ll need to download and install the 
runtime components of Visual C++ Libraries from Microsoft's website.

http://www.microsoft.com/downloads/details.aspx?
familyid=9B2DA534-3E03-4391-8A4D-074B9F2BC1BF&displaylang=en
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4.3. Linux

I have to say that I’m not very familiar with Linux platform and therefore there is no special build of 
mMass available for Linux. Nevertheless,  I am always testing and debugging mMass on my virtual 
version of Debian distribution to make it work properly and to retain application native look. If you want 
to run mMass on Linux see the following chapter to run it from the source code.

4.4. Running from Source

mMass belongs to the wide family of open source software so why not to modify it? All you need to do is 
download and unpack the mMass’s source ZIP archive and then do what you can. There are some 
additional modules and libraries needed to run mMass,  however, all of them are available for free and 
easy to install.

Dependencies

Python (http://www.python.org) “Python is a programming language that lets you work more quickly 
and integrate your systems more effectively. You can learn to use Python and see almost immediate gains 
in productivity and lower maintenance costs.”

wxPython (http://www.wxpython.org) “wxPython is a GUI toolkit for the Python programming 
language. It allows Python programmers to create programs with a robust,  highly functional graphical 
user interface, simply and easily. It is implemented as a Python extension module (native code) that wraps 
the popular wxWidgets cross platform GUI library, which is written in C++.”

NumPy (http://www.numpy.org) “NumPy is the fundamental package needed for scientific computing 
with Python.  It contains among other things: a powerful N-dimensional array object, sophisticated 
(broadcasting) functions, tools for integrating C/C++ and Fortran code, useful linear algebra, Fourier 
transform, and random number capabilities.”

Please note that current version of mMass was developed and tested using Python 2.7, wxPython 
2.8.12.1 and NumPy 1.5.  I cannot guarantee that mMass will work with different version of 
particular libraries.

Compiling C-code

In addition to installing all of the above libraries and modules you’ll need to compile a piece of C code 
used to speed up data processing. It can be done very easily with the “setup.py” script located in the 
“mspy” folder.

On Mac OS X go to the “mspy” folder and run compilation command in Terminal, then locate resulted 
“calculations.so” file in the build folder and move it to “mspy”. The compilation command should be 
like:

python setup.py build

On MS Windows go to the “mspy” folder and run compilation command in Command Prompt, then 
locate resulted “calculations.pyd” file in the build folder and move it to “mspy”. If you are using MinGW 
(http://www.mingw.org) the compilation command should be like:

python setup.py build --compiler=mingw32

On Linux go to the “mspy” folder and run compilation command in Terminal, then locate resulted 
“calculations.so” file in the build folder and move it to “mspy”. The compilation command should be 
like this:
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python setup.py build

Please note that in order to compile the C part of mMass on Linux, you need to have the “-dev” 
package of Python installed.

Running Application

To start up mMass go to mMass’s main folder and simply run the following command:

python mmass.py

Making Application Bundle

If you want to make your own application bundle for Mac OS X or MS Windows you need to have 
py2app (http://pypi.python.org/pypi/py2app) or py2exe (http://pypi.python.org/pypi/py2exe) respectively. 
After installing the corresponding utility you can make the bundle simply by using “setup.py” script 
located in mMass’s main folder. Just go to the folder and run the following command:

On Mac OS X

python setup.py py2app

On MS Windows

python setup.py py2exe
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5. User Interface
5.1. Application Layout

Beside the standard elements,  like toolbar etc., mMass’s user interface is divided into the three main parts: 
Documents Panel, Spectrum Viewer and Peaklist Panel.  You can choose from several different 
application layouts via Window menu.  All processing and analyzing modules and tools are available in 
the form of floating panels to enable direct validation of results and acquired data. 

intensity bar
peaklist panel

peak editorspectrum toolsview optionsdocuments panel

main toolbar

spectrum viewer

gel view
position bar

mMass’s user interface.

5.2. Main Menu

File

New - creates a blank document with no data. In those cases where data are available in the form of 
printed peak list only you can use the blank document to manually define peak list and to analyze it in 
mMass. This feature can also be used to create a document containing just a protein or peptide sequence 
to simulate digestion, fragmentation or isotopic pattern or to make a personal sequence database.

New from Clipboard - creates new document from clipboard data.

Open - opens document.

Open Recent - opens one of the recent documents.

Close - closes selected document.

Close All - closes all opened documents.

Save - saves selected document into mMass’s native format.
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Save As - saves selected document as a new file.

Save All - saves all opened documents.

Export - exports current spectrum image, spectrum points or peak list.

Print Spectrum - prints current spectrum view.

Analysis Report - generates analysis report for selected document.

Document Info  - shows document information panel for selected document. Various items can be 
specified such as analysis title, operator’s name, contact, institution, instrument, spectrum parameters 
and analysis notes. It is generally good idea to fill up this information if you want to share the analysis 
with other people.

Preferences - shows application preferences dialog. (In the mMass menu for OS X)

Quit - quits application. (In the mMass menu for OS X)

View

Spectrum Canvas → Legend - shows or hides legend in spectrum viewer.

Spectrum Canvas → Gridlines - shows or hides gridlines in spectrum viewer.

Spectrum Canvas → Minor Ticks - shows or hides minor axes ticks in spectrum viewer.

Spectrum Canvas → Data Points - shows or hides spectrum data points on detailed zoom.

Spectrum Canvas → Position Bars - shows or hides position bars in spectrum viewer.

Spectrum Canvas → Gel View - shows or hides gel-view in spectrum viewer.

Spectrum Canvas → Gel View Legend - shows or hides legend in gel-view.

Spectrum Canvas → Cursor Tracker - shows or hides cursor tracker in spectrum viewer.

Spectrum Canvas → Check Limits - block ranges outside documents boudaries.

Labels → Show/Hide Labels - shows or hides peak labels in spectrum viewer.

Labels → Show/Hide Label Ticks - shows or hides ticks for peak labels.

Labels → Label Charge - shows or hides charge value for peak labels.

Labels → Label Group - shows or hides group value for peak labels.

Labels → Label Background - shows or hides a solid white background for peak labels.

Labels → Horizontal/Vertical Labels - shows peak labels horizontally or vertically.

Labels → Allow Overlapping - enables or disables automatic managing of labels overlaps.

Labels → Labels in All Documents - shows or hides peak labels in all visible spectra.

Notations → Show/Hide Notations - shows or hides annotated or matched peaks.

Notations → Notation Marks - shows or hides marks for annotated or matched peaks.
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Notations → Notation Labels - shows or hides labels for annotated or matched peaks.

Notations → Notation m/z - shows or hides m/z for annotated or matched peaks.

Spectrum Ruler → m/z - shows or hides cursor m/z position in bottom bar.

Spectrum Ruler → Distance - shows or hides cursor distance value in bottom bar.

Spectrum Ruler → ppm - shows or hides cursor distance ppm value in bottom bar.

Spectrum Ruler → Charge - shows or hides calculated charge in bottom bar.

Spectrum Ruler → Mass - shows or hides calculated neutral mass in bottom bar.

Spectrum Ruler → Area - shows or hides calculated cursor selection area in bottom bar.

Peak List Columns - shows or hides peak list columns.

Autoscale Intensity - enables or disables automatic scaling of intensity axis.

Normalize Intensity - enables or disables normalization of intensity axis for all spectra.

Set Mass Range - defines current mass range in spectrum canvas.

Flip Spectrum - flips selected spectrum vertically.

Offset Spectrum - specifies intensity offset for current spectrum.

Clear All Offsets - clears intensity offsets for all spectra.

Canvas Properties - additional options for spectrum canvas (gel height, mass precision, font sizes etc.).

Processing

Undo - reverts back last operation. Most of the operations in mMass can be undone such as all processing 
functions or editing of labels, matches and annotations. However, only one step back is currently 
available.

Peak Picking - automatically finds and labels peaks in selected document.

Deisotoping - automatically assigns charges and deletes isotopes in current peak list. 

Deconvolution - makes duplicated document with deconvoluted peak list.

Correct Baseline - corrects baseline in selected spectrum.

Smooth Spectrum - smooths selected spectrum.

Crop - crops spectrum points and peak list in selected document.

Math Operations - normalize, combine, subtract or multiply spectra.

Batch Processing - apply processing steps in batch. 

Calibration - calibrates data in selected document using internal, external or statistical calibration.

Swap Data - swaps data between profile spectrum and peak list. For some formats it is not possible to see 
whether data should be handled like spectrum points or peak list. This function can be used to swap 
spectrum points to peak list data if the default decision was wrong.
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Sequence

New - creates new sequence object in selected document.

Import - imports sequence object from a file into selected document.

Edit Sequence - shows sequence editor with selected sequence.

Edit Modifications - shows sequence modifications editor with selected sequence.

Digest Protein - generates digestion peptides from selected sequence.

Fragment Peptide - generates fragments from selected sequence.

Mass Search - searches for peptide corresponding to given m/z value within selected sequence.

Show Isotopic Pattern - sends current sequence into Mass Calculator tool.

Send to Envelope Fit - sends current sequence into Envelope Fit tool.

Calibrate by Matches - uses current sequence matches as reference masses for data re-calibration.

Delete All Matches - deletes all the matches for selected sequence.

Delete Sequence - deletes selected sequence object.

Sort By Titles - sorts all sequences in selected document by titles.

Tools

Spectrum Ruler - sets mouse tool to measure distances, charge or area in a spectrum.

Label Peak - sets mouse tool to label peaks in selected spectrum.

Label Point - sets mouse tool to label exact points in selected spectrum.

Label Envelope - sets mouse tool to precisely label monoisotopic peak, isotopes or envelope centroid.

Delete Label - sets mouse tool to delete labels in selected spectrum.

Offset Spectrum - sets mouse tool to offset spectrum intensity.

Periodic Table - shows periodic table of elements.

Mass Calculator - calculates ion series and isotopic pattern for specified molecular formula.

Mass to Formula - generates elemental composition for given m/z value.

Mass Defect Plot - clusterizes and visualizes peaks based on their mass defect.

Mass Filter - removes or annotates contaminant masses.

Compounds Search - searches for specified compounds and adducts within selected document.

Peak Differences - generates table of peak differences to searches for amino acids or any m/z difference.

Compare Peak Lists - compare multiple peak lists.

Spectrum Generator - generates artificial spectrum from current peak list.
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Envelope Fit - determine heavy atoms exchange by fitting theoretical profiles to measured data.

Mascot PMF - sends selected peak list to Mascot’s Peptide Mass Fingerprint tool.

Mascot MS/MS Ion Search - sends selected peak list to Mascot’s MS/MS Ion Search tool.

Mascot Sequence Query - sends selected peak list to Mascot’s Sequence Query tool.

ProFound Search - sends selected peak list to ProFound Search tool.

Protein Prospector MS-Fit - sends selected peak list to Protein Prospector MS-Fit Search tool.

Protein Prospector MS-Tag - sends selected peak list to Protein Prospector MS-Tag Search tool.

Libraries

Compounds - shows compounds library editor.

Modifications - shows modifications library editor.

Monomers - shows monomers library editor.

Enzymes - shows shows enzymes library editor.

Reference Masses - shows reference masses library editor.

Mascot Servers - shows Mascot servers library editor.

Presets - shows presets library editor.

Links

Direct links to popular tools, databases and knowledge servers related to mass spectrometry.

Help

Homepage - opens mMass’s website in a default web browser.

Support Forum - opens mMass’s forum website in web browser.

Twitter - opens mMass’s Twitter account in web browser.

Papers to Cite - shows related papers in web browser.

Make a Donation - shows donation page in web browser.

Check for updates - checks for available updates.

5.3. Toolbar

 - Open document dialog

 - Save current document

 - Print current Spectrum Viewer content

 - Processing tools panel
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 - Calibration tool panel

 - Sequence tools panel

 - Periodic Table panel

 - Mass Calculator tools panel

 - Mass to Formula tool panel

 - Mass Defect Plot tool panel

 - Mass Filter tool panel

 - Compound Search tool panel

 - Peak Differences tool panel

 - Compare Peak Lists tool panel

 - Spectrum Generator tool panel

 - Envelope Fit tool panel

 - Mascot Search tools panel

 - ProFound Search tool panel

 - Document Info panel

 - Analysis Report

 - Export tools panel

5.4. Documents Panel

The main purpose of Documents Panel is to provide a structured view of loaded documents with all its 
sub-elements. In this panel, each element of selected document can be edited by double-clicking or 
processed via specific command or context menu. Most of the sequence related functions are also 
available via the main menu Sequence.

add blank document or sequence
delete item

spectrum colour and visibility bullet

user annotations

sequence matches

sequence title

document title

peak m/z, (match error) and annotation

Documents Panel.
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Document

➡ To add blank document:
Press  button from the bottom toolbar and select New Document,  or choose File → New from the 
main menu.

➡ To select document for analysis:
Click on any sub-element of the document you want to select. Selected document is marked by a 
bold title.

➡ To make a document copy:
Right-click on the document title and choose Duplicate Document.

➡ To temporarily hide document in spectrum viewer:
Click on the color bullet next to document title.

➡ To temporarily show only one document:
Click on the document title or bullet while holding Alt or Ctrl key. Click again to revert all 
documents to the previous state.

➡ To change document title, information or notes:
Double-click on the document title, or choose File → Document Info  from the main menu to show 
up Document Info panel. See Document Information chapter for more details.

➡ To vertically flip document in spectrum viewer:
Right-click on the document title and choose Flip Spectrum, or choose View → Flip Spectrum from 
the main menu.

➡ To offset spectrum intensity in spectrum viewer:
Right-click on the document title and choose Offset Spectrum, or choose View → Offset Spectrum 
from the main menu to show up offset dialog. Set Intensity offset and press Offset button.

➡ To clear spectrum offset:
Right-click on the document title and choose Clear Offset. Choose View → Clear Offsets from the 
main menu to clear offset for all opened documents.

➡ To change document colour:
Right-click on the document title and choose Change Colour.

➡ To change spectrum line style:
Right-click on the document title and choose a style from the Line Style menu.

➡ To delete all annotations and sequence matches:
Right-click on the document title and choose Delete All Notations.

➡ To close document:
Right-click on the document title and select Close Document, press  button from the bottom 
toolbar and choose Close Document, or choose File → Close from the main menu.

➡ To close all documents:
Right-click on any document title and select Close All Documents, press  button from the bottom 
toolbar and choose Close All Documents, or choose File → Close All from the main menu.

Please note that spectrum offset is applied only if normalization is disabled.

Please note that normalization and spectrum offset do not modify any document data. These are just 
visualization tools.
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User Annotations

It is possible to add a user annotation to any peak in a peak list. You can specify annotation Label, which 
is then shown in Documents Panel, and assign molecular Formula and Theoretical m/z value. All the 
annotations with theoretical m/z value can be used as calibration standards to re-calibrate your data. If the 
molecular formula is specified you can generate its isotopic pattern to see the difference between 
theoretical and measured peak.

Annotation dialog.

➡ To add user annotation:
Double-click on the peak in Peaklist Panel or press  button from the bottom toolbar of Peaklist 
Panel to show up annotation dialog and type your annotation.

➡ To edit user annotation:
Double-click on the annotation to show up annotation dialog and edit the annotation.

➡ To delete user annotation:
Right-click on any annotation and select Delete Annotation, or press  button from the bottom 
toolbar and choose Delete Annotation.

➡ To delete all user annotations:
Right-click on any annotation or the annotations root and select Delete All Annotations,  or press  
button from the bottom toolbar and choose Delete All Annotations.

➡ To highlight user annotation in spectrum viewer:
Click on the annotation and spectrum moves to the m/z value. Small red arrow shows up on m/z axis 
of the spectrum.

➡ To show or hide user annotation labels in spectrum viewer:
Choose View → Notations → Show/Hide Notations from the main menu and click on the 
annotations root. You can specify the information to show using View → Notations menu.

➡ To show isotopic pattern of user annotation:
Right-click on the annotation and select Show Isotopic Pattern. Mass Calculator panel shows up 
with the annotation formula and corresponding peak charge. This function is available only if 
molecular formula and charge is specified in annotation dialog. See Mass Calculator chapter for 
more information.

➡ To generate molecular composition for annotated m/z:
Right-click on the annotation and select Send to Mass to Formula. Mass to Formula panel shows up 
with the annotation m/z and corresponding peak charge. See Mass to Formula chapter for more 
information.

➡ To re-calibrate data by user annotations:
Right-click on any single annotation or annotations root and select Calibrate by Annotations.  All the 
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user annotations will be send to Calibration panel. Only those annotations with specified theoretical 
m/z value can be used for data calibration. See Calibration chapter for more information.

Sequence

In order to use some mMass’s tools such as Protein Digest or Peptide Fragmentation, specific sequence 
object must be defined. All sequence matches are stored in the similar way as user annotations and there 
are the same features available as well. See Sequence Tools chapter for more information about sequence 
editing and processing.

➡ To add new sequence:
Press  button from the bottom toolbar and select New Sequence,  or choose Sequence → New 
Sequence from the main menu. See Sequence Tools chapter for more information.

➡ To edit sequence:
Double-click on the sequence title and Sequence Editor shows up. See Sequence Tools chapter for 
more information.

➡ To delete sequence:
Click on the sequence title and press Command+Backspace or Delete, or press  button from the 
bottom toolbar and choose Delete Sequence.

➡ To edit sequence match:
Double-click on the sequence match to show up annotation dialog and edit the annotation.

➡ To delete sequence match:
Right-click on any sequence match and select Delete Match,  or press  button from the bottom 
toolbar and choose Delete Match.

➡ To delete all sequence matches:
Right-click on any sequence match or the sequence title and select Delete All Matches, or press  
button from the bottom toolbar and choose Delete All Matches.

➡ To highlight sequence match in spectrum viewer:
Click on the sequence match and spectrum moves to the m/z value. Small red arrow shows up on m/
z axis of the spectrum.

➡ To show or hide sequence match labels in spectrum viewer:
Choose View → Notations → Show/Hide Notations from the main menu and click on the sequence 
root. You can specify the information to show using View → Notations menu.

➡ To show isotopic pattern of sequence match:
Right-click on the sequence match and select Show Isotopic Pattern. Mass Calculator panel shows 
up with the peptide formula and corresponding peak charge. See Mass Calculator chapter for more 
information.

➡ To send sequence match formula to Envelope Fit:
Right-click on the annotation and select Send to Envelope Fit. Envelope Fit panel shows up with the 
peptide formula and corresponding peak charge. See Envelope Fit chapter for more information.

➡ To re-calibrate data using sequence matches:
Right-click on any single match or sequence title and select Calibrate by Matches. All the matches 
will be send to Calibration panel. See Calibration chapter for more information.

5.5. Spectrum Viewer

Since most time in data interpretation is spent manipulating spectra (e.i. moving, scaling, zooming etc.), 
Attention was paid to make these functions as easy and user friendly as possible. Everything is accessible 
by mouse, keyboard or combination of both.  Position bars always indicate your current position, zoom 
and relative intensity within the context of shown data. Vertical flipping, spectrum offset and gel view can 
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be used to effectively compare your samples with a standard or blank spectrum. In addition, Spectrum 
Viewer offers some other useful features such as peak labeling tools and distance, charge or peak area 
measurements.

gel view position bar
document title

intensity bar

m/z charge cursor tracker

label tick

m/z
intensity

monoisotopic mark

annotation mark

baseline mark
cursor info

spectrum toolsview options

Spectrum Viewer panel.

Spectrum Manipulations

➡ To zoom spectrum range:
Select the m/z range with right or middle mouse button pressed.

➡ To zoom continuously from cursor position:
Move the mouse cursor to desired m/z position and scroll the mouse wheel while holding Alt or Ctrl 
key.

➡ To zoom from center of current view:
Use Left and Right arrows keys on your keyboard while holding Alt key.

➡ To zoom from beginning of current view:
Drag the m/z axis horizontally with right mouse button pressed.

➡ To move spectrum horizontally:
Scroll the mouse wheel or drag the m/z axis horizontally with left mouse button pressed. If you 
prefer using keyboard, use Left, Right, PageUp, PageDown, Home and End keys.

➡ To scale intensity axis:
Scroll the mouse wheel while holding Shift key or the cursor placed within the y-axis area or drag the 
intensity axis vertically with right mouse button pressed.

➡ To scale intensity axis automatically to fit current spectrum range:
Press  button from the bottom toolbar, or choose View → Autoscale Intensity from the main 
menu.

➡ To show full mass range:
Double-click on the m/z axis.
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➡ To show full intensity range:
Double-click on the intensity axis.

➡ To show full spectrum:
Double-click anywhere in the spectrum.

➡ To show specified mass range:
Choose View → Set Mass Range from the main menu. Specify the range and press OK button.

View Options

There are different view options available for Spectrum Viewer. Those commonly used are available 
directly from the bottom toolbar, others can be accessed via the application main menu View.

show or hide gel view
show or hide cursor tracker

autoscale intensity axis
normalize intensity axis

show or hide position bars

show or hide labels
show or hide labels ticks
show or hide notation marks

labels orientation

Bottom toolbar with the most common Spectrum Viewer options.

➡ To show or hide gridlines:
Choose View → Spectrum Canvas → Show/Hide Gridlines from the main menu.

➡ To show or hide legend:
Choose View → Spectrum Canvas → Show/Hide Legend from the main menu.

➡ To show or hide position and intensity bar:
Press  button from the bottom toolbar, or choose View → Spectrum Canvas → Show/Hide 
Position Bars from the main menu.

➡ To show or hide gel view:
Press  button from the bottom toolbar,  or choose View → Spectrum Canvas → Show/Hide Gel 
View from the main menu.

➡ To show or hide gel view legend:
Choose View → Spectrum Canvas → Show/Hide Gel View Legend from the main menu.

➡ To show or hide cursor tracker:
Press  button from the bottom toolbar, or choose View → Spectrum Canvas → Show/Hide Cursor 
Tracker from the main menu.

➡ To enable or disable data points:
Choose View → Spectrum Canvas → Show/Hide Data Points from the main menu. Data points are 
typically visible on detailed zoom only.

➡ To show or hide labels:
Press  button from the bottom toolbar, or choose View → Labels → Show/Hide Labels from the 
main menu.

➡ To show or hide labels ticks:
Press  button from the bottom toolbar,  or choose View → Labels → Show/Hide Label Ticks from 
the main menu.

➡ To show or hide charge in labels:
Choose View → Labels → Show/Hide Label Charge from the main menu.

mMass User’s Guide

© 2005–2013 Martin Strohalm  Page 27



➡ To show or hide solid background for labels:
Choose View → Labels → Show/Hide Label Background from the main menu.

➡ To change labels orientation:
Press  button from the bottom toolbar, or choose View → Labels → Horizontal/Vertical Labels 
from the main menu.

➡ To allow overlapping labels:
Choose View → Labels → Allow Overlapping from the main menu.

➡ To show labels in all documents:
Choose View → Labels → Labels in All Documents from the main menu. Only labels from the 
selected document will be shown if this feature is disabled.

➡ To show or hide notations:
Press  button from the bottom toolbar,  or choose View → Notations → Show/Hide Notations 
from the main menu.

➡ To show or hide notation marks:
Choose View → Notations → Notation Marks from the main menu.

➡ To show or hide notation labels:
Choose View → Notations → Notation Labels from the main menu.

➡ To show or hide notation m/z:
Choose View → Notations → Notation M/Z from the main menu.

➡ To enable intensity autoscale:
Press  button from the bottom toolbar, or choose View → Autoscale Intensity from the main 
menu.

➡ To enable intensity normalization:
Press  button from the bottom toolbar, choose View → Normalize Intensity from the main menu.

➡ To flip spectrum vertically:
Right-click on the document title in Documents Panel and choose Flip Spectrum.

➡ To offset spectrum intensity:
Right-click on the document title in Documents Panel and choose Offset Spectrum, or choose View 
→ Offset Spectrum from the main menu to show up offset dialog. Set Intensity offset and press 
Offset button. You can choose Offset spectrum tool from the bottom toolbar as well.

➡ To clear spectrum offset:
Right-click on the document title and choose Clear Offset. Choose View → Clear Offsets from the 
main menu to clear offset for all documents.
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Canvas Properties dialog.

➡ To set m/z precision (number of digits):
Choose View → Canvas Properties from the main menu to show up Canvas Properties dialog and 
move the m/z precision slider. This settings is used for all occurrences of mass throughout the 
application.

➡ To set intensity precision (number of digits):
Choose View → Canvas Properties from the main menu to show up Canvas Properties dialog and 
move the Intensity precision slider.  This settings is used for all occurrences of intensity throughout 
the application.

➡ To set gel height:
Choose View → Canvas Properties from the main menu to show up Canvas Properties dialog and 
move the Gel height slider.

➡ To set position and intensity bars height:
Choose View → Canvas Properties from the main menu to show up Canvas Properties dialog and 
move the Bars height slider.

➡ To set axis and legend font size:
Choose View → Canvas Properties from the main menu to show up Canvas Properties dialog and 
move the Canvas font size slider.

➡ To set label font size:
Choose View → Canvas Properties from the main menu to show up Canvas Properties dialog and 
move the Label font size slider.

➡ To set max length of notation label:
Choose View → Canvas Properties from the main menu to show up Canvas Properties dialog and 
move the Notation label size slider. Longer notations will be cropped and with “...” tailing.

Spectrum Tools

There are several mouse tools available for Spectrum Viewer such as Spectrum Ruler, Label Peak,  Label 
Point,  Label Envelope, Delete Labels and Offset Spectrum. All the tools parameters are specified in 
Baseline Correction, Peak Picking and Deisotoping panels.
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label envelope
delete labels

offset spectrumspectrum ruler
label peak

label point

Bottom toolbar with Spectrum tools.

➡ To measure distance in spectrum:
Press  button from the bottom toolbar and drag mouse in the spectrum with left mouse button 
pressed. Several values can be shown in the bottom toolbar according to the View menu settings.

➡ To label peak:
Press  button from the bottom toolbar and select desired peak in the spectrum. Only the most 
intense peak in the selection will be labeled. See Data Processing chapter for more information.

➡ To label point:
Press  button from the bottom toolbar and click at desired point in the spectrum. A cursor cross 
mark tracks the spectrum line until you release the mouse button. See Data Processing chapter for 
more information.

➡ To label isotopes or envelope centroid:
Press  button from the bottom toolbar and position the mouse cursor at first isotope of a cluster. 
Scroll the mouse wheel while holding Shift button to set charge or Shift+Ctrl (Shift+Alt on Mac OS 
X) to set isotopes involved in calculations. Positions of involved isotopes are marked by black 
circles in Spectrum Viewer.  Depending on the value specified in Deisotoping panel, 1st selected 
isotope, monoisotopic peak, all isotopes or envelope centroid is labeled after left mouse button click.

➡ To delete labels:
Press  button from the bottom toolbar and select area where the labels should be deleted. Only 
those peaks/labels where its m/z and intensity values fall into the selected area will be deleted.

➡ To automatically set labeled peak as monoisotopic:
From the main menu choose Processing → Deisotoping and check the Set labels as monoisotopes 
checkbox.

➡ To measure charge state and neutral mass in spectrum:
Press  button from the bottom toolbar and drag mouse in the spectrum with left mouse button 
pressed. Drag between two adjacent isotopes or drag between adjacent protein peaks. Corresponding 
charge state and neutral mass will be shown in the bottom toolbar if enabled in the View menu.

➡ To measure peak area in spectrum:
Press  button from the bottom toolbar and drag mouse in the spectrum with left mouse button 
pressed to define area edges.  Corresponding area is shown in the bottom toolbar if enabled in the 
View menu. Current baseline settings is used to determine bottom edge. Open Baseline Correction 
panel to adjust the baseline.

➡ To enable or disable cursor info/spectrum ruler values:
Check the values in the main menu View → Spectrum Ruler or right-click in the bottom toolbar and 
select items to show.

➡ To offset spectrum intensity:
Press  button from the bottom toolbar and drag mouse in the spectrum with left mouse button 
pressed. Distance shows in the bottom toolbar and next to the cursor if Cursor Tracker is enabled. 
Current spectrum will be shifted after releasing the mouse button. Choose View → Offset Spectrum 
from the main menu to set spectrum offset manually.

See Senko M. et al. 1995 JASMS for more information about monoisotopic peak determination.
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It is sometimes little bit tricky to use Label Envelope tool, especially for high-resolution data. Try to 
use wider zoom range to see whole envelope and set the charge state and number of isotopes 
involved. Then zoom to the first isotope and click onto its center.  All the isotopes should be labeled 
correctly. If not, try to use Isotope mass shift correction in Deisotoping panel.

Please note that for Spectrum Ruler tool the calculated charge is shown as float number, however,  its 
rounded value is used for calculation of corresponding neutral mass.

Please note that spectrum offset is just a visualization tool and no real data are changed.

Please note that spectrum offset cannot be applied when normalized view is turned on.

5.6. Peaklist Panel

Peaklist Panel provides a table of all labeled peaks in selected document. For each peak, various 
parameters can be shown, according to current settings. In addition, new peaks can be manually added, 
edited or removed or any user annotation can be specified.

peak list

peak editor

add peak
delete peaks

annotate selected peak
show or hide peak editor

number of peaks in current peak list

Peaklist Panel with peak editor enabled.

• m/z - peak’s m/z

• a.i. - peak’s native intensity (no baseline correction)

• base - peak’s baseline intensity

• int. - peak’s corrected intensity (baseline subtracted)

• r. int. - peak’s relative intensity (in % of the most intense peak)

• s/n - peak’s signal-to-noise ratio

• z - peak’s charge
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• mass - peak’s recalculated neutral mass

• fwhm - peak’s full width at half maximum

• resol. - peak’s resolution

• group - peak’s group name

➡ To set visible columns:
Right-click on the peak list header and choose column to show / hide or choose View → Peak List 
Columns from the main menu.

➡ To manually add new peak:
Press  button from the bottom toolbar to show and clear peak editor, fill-up the peak parameters 
and press Add button.

➡ To edit peak parameters:
Press  button from the bottom toolbar to show peak editor and click on the peak. Edit peak 
parameters and press Update button.

➡ To duplicate peak with different parameters:
Press  button from the bottom toolbar to show peak editor and click on the peak. Change peak 
parameters and press Add button.

➡ To delete peaks:
Select the peaks you want to delete and press Command+Backspace or Delete,  or press  button 
from the bottom toolbar and choose Delete Selected. You can use Delete Labels tool in Spectrum 
Viewer as well.

➡ To delete peaks by threshold:
Press  button from the bottom toolbar and choose Delete by Threshold to show up threshold 
dialog. Set Minimal value and Threshold type and press Delete button. Another way is to sort peak 
list by specific value, selecting and deleting unwanted peaks.

➡ To delete all peaks:
Press  button from the bottom toolbar and choose Delete All.

➡ To annotate peak:
Double-click the peak or press  button in the bottom toolbar to show up annotation dialog and 
type your annotation.

➡ To highlight peak in spectrum viewer:
Click on the peak and spectrum moves to the m/z value. Small red arrow shows up on m/z axis of 
the spectrum. Current zoom range remains the same.

➡ To copy selected peaks into clipboard:
Select the peaks you’d like to copy and press Command+C (Ctrl+C on MS Windows and Linux).

➡ To export peak list:
Press  button from the main toolbar,  or choose File → Export from the main menu to show up 
Export dialog, and select Export Peak List  tool. See Export chapter for more information.
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6. Document Basics
6.1. Supported Formats

mMass supports several mass spectrometry formats. Popular XML-based formats like mzData (http://
www.psidev.info), mzXML (http://tools.proteomecenter.org) and mzML  (http://www.psidev.info),  which 
are open source and well documented, are fully supported. The MGF (Mascot Generic Format) data 
format is supported in its standard form. Mass spectra and peak list data can also be imported from an 
ASCII file consisting of m/z and intensity columns separated by a tab, space, comma or semicolon.

Most of the native vendors’  software also support copying m/z and intensity values directly into system 
clipboard from which they can be easily pasted into mMass as a new document.

Since it is often impossible to obtain the manufacturer's description of their native file formats,  they are 
not currently supported. However, if you have a Bruker’s CompassXport tool installed on your computer 
it is automatically used to convert and open raw data from all Bruker’s instruments. This tool is available 
for free at www.bdal.de,  unfortunately, for MS Windows platform only. In mMass’s preferences you can 
specify whether mzData, mzXML  or mzML format will be used for conversion and whether profile 
spectrum or peak list only will be extracted.

mMass is so-called a “single spectrum editor” therefore experiments such as LC-MS runs cannot be fully 
analyzed by mMass.  However, it is possible to open any selected scan from such runs to analyze it 
separately. Sure, it does not make sense for lots of LC-MS experiments but it can be useful in many cases.

6.2. Open Document

➡ To open document:
Drag the document file into mMass’s main window or choose File → Open from the main menu.

➡ To open selected scan from LC-MS run:
Drag the document file into mMass’s main window or choose File → Open from the main menu. If 
document contains more scans, Select Scan dialog shows up. Select scan(s) you’d like to open and 
press Open button. Total ion chromatogram and base peak chromatogram is available if 
corresponding parameters are found in the data.

➡ To open spectrum from Bruker’s instruments:
Drag the spectrum folder into mMass’s main window or choose File → Open from the main menu 
and locate the analysis.baf,  analysis.yep or fid file. You need to have CompassXport tool installed. 
This function is currently available for MS Windows platform only.

➡ To import spectrum from clipboard:
Be sure to copy only m/z and intensity columns into clipboard. Than choose File → New from 
Clipboard from the main menu. If mMass detects some problem while reading your data a small text 
dialog appears to let you correct the errors. Typically, this happens when you copy your data with 
column headers.

For ASCII XY and some mzXML  documents mMass is unable to determine whether the document 
contains spectrum points or just centroides of peaks and chooses spectrum as default. If this decision 
isn’t correct you can swap the data between line spectrum and peak list by choosing Processing → 
Swap Data from the main menu.

mMass allows for file association using server-client approach listening on port 65456. If you 
encounter any conflict using this particular port, change the “serverPort” value in config.xml file. 
On Mac OS X, all configuration files can be found under “~/Library/Application Support/mMass/”. 
On MS Windows and Linux systems, all configuration files can be found under “configs” folder, 
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located directly under the mMass’s main folder. This feature is not necessary on Mac OS X and the 
server is disabled by default, however, file association still works correctly.

Please note that CompassXport tool does not allow non-ascii characters in a document path.

Select Scan dialog.

6.3. Blank Document

One of the unique features of mMass is the ability to make a blank document and manually create peak 
list. This feature is particularly useful in those cases where raw spectrum is unavailable and user only has 
a spectrum image or printed list of labelled peaks. Such is often the situation in laboratories that do not 
have their own instruments and have to send their samples to other laboratories. This feature gives such 
laboratories the chance to analyze MS data themselves. Once the peak list is prepared, all interpretation 
tools can be used. (See Peaklist Panel chapter for more information about peak list editing.) Blank 
documents can also be used for protein digest or peptide fragmentation simulations or to make a personal 
database of sequences which can be easily imported into any document.

➡ To open blank document:
Press  button from the bottom toolbar and select New Document or choose File → New from the 
main menu.

6.4. Save Document

To retain all the information related to analysis such as protein sequence or user’s annotations mMass has 
its own document format to store the data (mSD format). This format is XML-based to be easily 
processed by other software.

➡ To save document:
Select the document in Documents Panel and choose File → Save from the main menu.
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6.5. Export

Export tools.

➡ To export spectrum image:
Press  button from the main toolbar or choose File → Export from the main menu to show up 
Export dialog,  and select Export Spectrum Image  tool. Specify export parameters and press 
Export button.

➡ To export spectrum points:
Press  button from the main toolbar or choose File → Export from the main menu to show up 
Export dialog, and select Export Spectrum Data  tool. Specify export parameters and press Export 
button.

➡ To export peak list:
Press  button from the main toolbar or choose File → Export from the main menu to show up 
Export dialog and select Export Peak List  tool. Specify export parameters and press Export 
button.

➡ To export spectrum image to vector format:
On Mac OS X and Linux platform you can use native support for PDF creation to export spectrum 
into vector format. From the main menu choose File → Print and select PDF. On MS Windows you 
need to have some PDF convertor installed first.  To be able to specify the image size you have to 
define appropriate paper.

To export spectrum images for screen presentation only, use 72 dpi. To export images for printing or 
publications use higher resolution and set the font and line scaling according to image size.

6.6. Print Spectrum

➡ To print spectrum:
Choose File → Print Spectrum from the main menu and current Spectrum Viewer contents will be 
printed.

Please note that whole spectrum canvas is redrawn internally to fill paper size. While m/z range is 
retained, intensity range can be slightly different if Autoscale Intensity option is enabled. To be sure 
the intensity range is the same as in the Spectrum Viewer just disable Autoscale Intensity option 
when printing.
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6.7. Document Info

Document Info panel provides some information about selected document and place to write your own 
description of the sample, analysis and results. It is generally good idea to fill up this information if you 
want to share the analysis with other people.

Document Summary

In the Document Summary part of Document Info panel you can specify document Title,  Operator’s name, 
Contact and Institution, used Instrument and measurement Date. You can save current values as a preset 
to use it later again.

Document Summary.

➡ To show document summary:
Press  button from the main toolbar or choose File → Document Info from the main menu to show 
up Document Info panel. Then press  button from the panel toolbar.

➡ To save current values as presets:
Write the information you’d like to save as presets. Press  button from the panel toolbar and 
choose Save as Presets. In the dialog write presets name and press Save button.

➡ To use saved presets:
Press  button from the panel toolbar and choose any of your presets from the pup-up menu.

➡ To delete saved presets:
Choose Libraries → Presets from the main menu to show up Presets Library editor. Choose the 
presets you’d like to delete and press Delete button.

➡ To rename saved presets:
Choose Libraries → Presets from the main menu to show up Presets Library editor. Choose the 
presets you’d like to rename, type the new name and press Rename button.

Spectrum Info

In the Spectrum Info part of Document Info panel you can specify Scan ID, Retention time, MS level 
Precursor m/z, Precursor charge and Polarity. In addition, number of spectrum points and total number  
of peaks in peak list are shown.
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Spectrum Info.

➡ To show spectrum info:
Press  button from the main toolbar or choose File → Document Info from the main menu to show 
up Document Info panel. Then press  button from the panel toolbar.

Analysis Notes

Analysis Notes provides a place to type you personal notes about sample preparation, sample analysis and 
interpretation results. These information will be also shown in analysis report. See Analysis Report 
chapter for more information.

Analysis Notes.

➡ To show analysis notes:
Press  button from the main toolbar or choose File → Document Info from the main menu to show 
up Document Info panel. Then press  button from the panel toolbar.

6.8. Analysis Report

Analysis report can be generated from selected document and all available information such as document 
info, current Spectrum Viewer content, user’s notes and annotations,  sequence, modifications and matches 
will be included. This report is generated in HTML format and automatically shows up in your web 
browser.
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Analysis report.

➡ To make analysis report:
Press  button from the main toolbar or choose File → Analysis Report from the main menu. Report 
shows up in your web browser.

➡ To sort data in report tables:
Click on appropriate column header in the report. Please note that this feature needs to have 
JavaScript enabled in your web browser.

It is generally good practice to write your analysis notes and results into document using Document 
Info tool prior to report generation. See Document Info chapter for more information.

On Mac OS X and Linux platform you can use native support for PDF creation to make PDF report. 
When the report shows up in your web browser choose File → Print and select PDF. On MS 
Windows you need to have some PDF convertor installed first.
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7. Data Processing
mMass offers number of common data processing functions such as mathematical operations, cropping, 
baseline correction, smoothing, peak picking, charging, deisotoping and deconvolution. In order to speed 
up data processing from different instruments you can define your own processing presets and use it 
frequently. In addition, you can process multiple documents at once using Batch Processing tool.

➡ To open data processing tool:
Press  button from the main toolbar and select the tool or choose specific tool from Processing 
menu.

➡ To undo last processing step:
From the main menu choose Processing → Undo.

➡ To save current values as presets:
Press  button from the panel toolbar and choose Save as Presets. In the dialog type the presets 
name and press Save button.

➡ To use saved presets:
Press  button from the panel toolbar and choose any of your presets from the pup-up menu.

➡ To delete saved presets:
Choose Libraries → Presets from the main menu to show up Presets Library editor. Choose the 
presets you’d like to delete and press Delete button.

➡ To rename saved presets:
Choose Libraries → Presets from the main menu to show up Presets Library editor. Choose the 
presets you’d like to rename, type the new name and press Rename button.

Please note that presets contain parameters from all the processing tools. If you load any presets, 
parameters for all the tools will be changed.

7.1. Math Operations

Simple math operations are available to normalize, combine, subtract overlay or multiply documents. 
Most of the operations can be applied to spectrum points only while a peak list is removed.

Math Operations tool.
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• Global operation - math operation to be applied to all visible documents. New document is 
generated a result.

• Basic operation - math operation to be applied to currently selected document.

• Spectrum A - document currently selected.

• Spectrum B - spectrum to be added or subtracted from current document.

➡ To open math operation tool:
Press  button from the main toolbar, then press  button from the panel toolbar or choose 
Processing → Math Operations from the main menu.

➡ To average all document:
Show/enable all documents to be averaged in the Documents Panel. In the Math Operations tool 
select “Average all visible” and  press Apply button to generate averaged spectrum.

➡ To sum all document:
Show/enable all documents to be summed in the Documents Panel. In the Math Operations tool 
select “Sum all visible” and  press Apply button to generate summed spectrum.

➡ To overlay all document:
Show/enable all documents to be overlaid in the Documents Panel. In the Math Operations tool 
select “Overlay all visible” and  press Apply button to generate overlaid spectrum.

➡ To normalize selected document:
Select a document in the Documents Panel.  In the Math Operations tool select “Normalize” and  
press Apply button to apply operation on selected document.

➡ To add spectrum to selected document:
Select a document in the Documents Panel. In the Math Operations tool select “Combine A + B” 
and the document to be added (Spectrum B). Press Apply button to apply operation on selected 
document.

➡ To subtract spectrum from selected document:
Select a document in the Documents Panel. In the Math Operations tool select “Subtract A - B” and 
the document to be subtracted (Spectrum B). Press Apply button to apply operation on selected 
document.

➡ To overlay spectrum with selected document:
Select a document in the Documents Panel. In the Math Operations tool select “Overlay max(A, B)” 
and the document to be overlaid (Spectrum B). Press Apply button to apply operation on selected 
document.

➡ To multiply selected document:
Select a document in the Documents Panel.  In the Math Operations tool select “Multiply A *” and 
specify multiplier value. Press Apply button to apply operation on selected document.

To be able to sum-up or subtract two spectra, both must have the same x-raster. Unfortunately, this is 
not often the case, therefore additional points needs to be added and resulted spectrum can easily 
became very huge and further processing very time-consuming!  Since x-raster is mostly changed by 
different calibrations, it is generally good idea to apply this processing prior to any re-calibration.

Please note that all of the user’s annotations and sequence matches will be removed after applying 
math operation. It is generally good idea to apply processing functions prior to any data 
interpretation.
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7.2. Crop

This function simply discards all the spectrum data points, labeled peaks, annotations and sequence 
matches which are out of the m/z range specified by Low mass and High mass parameters.

Crop tool.

• Low mass - data below this limit will be removed.

• High mass - data above this limit will be removed.

➡ To open crop tool:
Press  button from the main toolbar, then press  button from the panel toolbar or choose 
Processing → Crop from the main menu.

➡ To crop data:
Using Low mass and High mass values specify the m/z range to keep and press Apply button.

Using Crop tool to remove “matrix area” from MALDI-TOF mass spectra can significantly reduce 
number of spectrum data points and speed up further processing.

7.3. Baseline Correction

Especially for MALDI-TOF mass spectra of proteins a strong baseline distortion is common problem 
which needs to be corrected quite often. Using Baseline Correction tool, this processing step can be done 
very easily. Baseline is calculated from the spectrum noise as a median of all data points. Using Precision 
slider, baseline can be set to trace a spectrum shape precisely.  In addition, you can specify Relative offset 
to move calculated baseline down a bit. You can see calculated baseline while changing the parameters 
and when ready a preview can be generated. Specified baseline settings is also used for automatic Peak 
Picking tool to calculate baseline for each labeled peak.

Baseline Correction tool.

• Precision - baseline shape precision (1 = straight line).

• Relative offset - baseline shift.

➡ To open baseline correction tool:
Press  button from the main toolbar, then press  button from the panel toolbar or choose 
Processing → Smooth Spectrum from the main menu.
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➡ To preview corrected data:
Specify all the parameters and press Preview button. A temporary (red) corrected spectrum appears 
in Spectrum Viewer.

➡ To subtract baseline from data:
Specify all the parameters and press Apply button.

Please note that calculated baseline is shows in Spectrum Viewer while moving Precision or Relative 
offset slider. This feature can be very helpful to set baseline precisely.

Please note that current peak list and all the user’s annotations and sequence matches will be 
removed after applying baseline correction. It is generally good idea to apply processing functions 
prior to any data interpretation.

7.4. Smoothing

You can use this function to smooth the noise which distorts peak shape. There are three different 
smoothing Methods available - Moving Average, Gaussian and Savitzky-Golay. In general, Moving 
Average and Gaussian are much faster but causes significant intensity loss for sharp peaks. These 
methods should be preferentially used to smooth high-mass spectra where peaks are broader.  On the other 
hand, Savitzky-Golay filter is very slow but intensity loss is much lower. This method should be 
preferentially used to smooth low-mass spectra where peaks are sharp.  After setting all the parameters 
you can see a preview before processing your data.

Smoothing tool.

• Method - smoothing algorithm.

• Window size - smoothing window.

• Cycles - number of smoothing repetitions.

➡ To open smooth tool:
Press  button from the main toolbar, then press  button from the panel toolbar or choose 
Processing → Smooth Spectrum from the main menu.

➡ To preview smoothed data:
Specify all the parameters and press Preview button. A temporary (red) smoothed spectrum appears 
in Spectrum Viewer.

➡ To smooth data:
Specify all the parameters and press Apply button.

Always check the intensity loss for different peaks along the entire mass range. Use smaller Window 
size if the intensity loss is too strong.
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Please note that at least 4 data points within the smoothing window are needed for smoothing. No 
smoothing is applied if Window size is too narrow.

Please note that current peak list and all the user’s annotations and sequence matches will be 
removed after applying smoothing. It is generally good idea to apply processing functions prior to 
any data interpretation.

7.5. Peak Picking

As mentioned earlier in Spectrum Viewer chapter, there are specific tools to label peaks manually. 
However, this could be very annoying especially for data-rich spectra like those from FTICR MS or 
Orbitrap. Fortunately, an algorithm is incorporated into mMass to facilitate automatic peak picking. There 
are couple of basic steps involved in the peak picking algorithm:

• Baseline correction - if enabled, baseline and noise widths are calculated and used for each peak.

• Smoothing - if enabled, raw spectrum is smoothed temporarily to eliminate peak noise.

• Searching for local maxima - local maxima are temporarily labeled as potential peaks.

• Filtering by threshold - peaks bellow user intensity or S/N threshold are removed.

• Centroides calculation - peak centroides are calculated and unresolved peaks are grouped together.

• Filtering by threshold - peaks bellow user intensity or S/N threshold are removed.

• Removing shoulder peaks - if enabled, “shoulder peaks” for FTMS data are removed.

• Deisotoping - if enabled, deisotoping is applied to remove isotopes and calculate peak charges.

Peak Picking tool.

• S/N threshold - peaks bellow the signal to noise threshold will not be labeled.

• Abs. intensity threshold - peaks bellow the absolute intensity (peak intensity - baseline) threshold 
will not be labeled.

• Rel. intensity threshold - peaks bellow the relative intensity threshold will not be labeled.

• Picking height - picking height for centroides.

• Apply baseline - for each peak its baseline and noise width is calculated according to current baseline 
settings. See Baseline Correction chapter for more information.

• Apply smoothing - data will be smoothed prior to peak picking according to current smoothing 
settings. See Smoothing chapter for more information.

• Apply deisotoping - peak isotopes will be removed and charge calculated according to current 
deisotoping settings. See Deisotoping chapter for more information.
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• Remove shoulder peaks - small surrounding peaks called “shoulder peaks” occurring in FTMS data 
will be removed.

➡ To open peak picking tool:
Press  button from the main toolbar, then press  button from the panel toolbar or choose 
Processing → Peak Picking from the main menu.

➡ To label peaks:
Specify all the parameters and press Apply button. Follow the threshold line showed in Spectrum 
Viewer while changing the parameters.

Set current baseline in Baseline Correction panel before peak picking is applied.

Use smoothing for MALDI-TOF data of any kind.

If smoothing is enabled, don’t forget to check intensity loss for different peaks along the spectrum.

Smoothing significantly decreases number of local maxima, therefore speeds up peak picking.

If baseline, smoothing or deisotoping is enabled, don’t forget to check corresponding panels.

Please note that baseline, peak picking and deisotoping parameters are used for manual peak 
picking tools as well.

Please note that all the user’s annotations and sequence matches will be removed after applying 
peak picking. It is generally good idea to apply processing functions prior to any data interpretation.

7.6. Deisotoping

The main purpose of this tool is to remove unwanted peak isotopes after peak picking. However, in order 
to find the isotopes a peak charge needs to be calculated, therefore this tool can also be used for charge 
determination.

Starting from specified Maximum charge, for every peak its isotopes are searched using corresponding 
isotopic mass difference (1.00287/abs(z)) ± Isotope mass tolerance. If at least one isotope is found, parent 
peak is set as the monoisotopic with current charge state.  If no isotope is found, current charge state is 
decreased (abs(z) - 1) and search cycle starts again for the same peak. Because of possible peak overlaps, 
theoretical isotopic pattern needs to be taken into account. Intensity of every isotope is compared with its 
theoretical value. If the intensity is matching theoretical value ± Isotope intensity tolerance, 
corresponding isotope is discarded from any subsequent search cycle. If the difference is over tolerance, 
corresponding isotope will be used as possible parent (monoisotopic) peak in subsequent search cycle. 
Since mMass is mostly used for proteomic data interpretation, the averagine (C4.9384 N1.3577 O1.4773 
S0.0417 H7.7583) is used to approximate theoretical isotopic patterns (Senko et al. 1995 AJMS).

mMass User’s Guide

© 2005–2013 Martin Strohalm  Page 44



Deisotoping tool.

• Maximum charge - maximum charge state to be searched.

• Isotope mass tolerance - tolerance for mass difference between adjacent isotopes.

• Isotope intensity tolerance - tolerance for intensity check between theoretical and measured isotope.

• Isotope mass shift - mass correction to the default isotope distance used (1.00287).

• Remove isotopes - all identified isotopes will be removed after processing.

• Remove unknown - all unknown peaks will be removed after processing.

• Label envelope tool - function applied to Label Envelope tool.

• Envelope intensity - method used to calculate final intensity of the envelope.

• Set labels as monoisotopes - manually labeled peaks are automatically set as monoisotopic.

➡ To open deisotoping tool:
Press  button from the main toolbar, then press  button from the panel toolbar or choose 
Processing → Deisotoping from the main menu.

➡ To deisotope peak list:
Specify all the parameters and press Apply button.

➡ To apply deisotoping automatically after peak picking:
In Peak Picking panel enable Apply deisotoping.

➡ To edit peak charge:
Press  in the Peaklist Panel bottom toolbar to show peak editor and click on the peak in the list. 
Set the new charge and press Replace button.

➡ To manually set peak as monoisotopic:
Press  in the Peaklist Panel bottom toolbar to show peak editor and click on the peak in the list. 
Check monoisotopic checkbox and press Replace button.

Use the Isotope mass shift to correct deuterium effect in H/D exchange experiments.

Please note the relationship between Maximum charge and Isotope mass tolerance. Isotope mass 
tolerance must be lower than 1.00287×(1/(z-1) - 1/z) to successfully distinguish z and z-1 charge.

Please note that the combination of averagine intensity distribution and higher Isotope intensity 
tolerance is generally applicable to wide range of organic compounds but can be very problematic if 
atoms like Cl, Fe, Hg, Pt etc. are incorporated.
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Please note that all the user’s annotations and sequence matches will be removed after applying 
deisotoping. It is generally good idea to apply processing functions prior to any data interpretation.

7.7. Deconvolution

ESI mass spectra typically contain same species in the form of different charge states, which can 
complicate data interpretation. Therefore a simple process called deconvolution is often used to 
recalculate all the multiply-charged species into singly-charged form. In addition, related peaks, 
originated from the same species but with different charge state, can be grouped together using either 
known peak’s FWHM value or default m/z window. By applying Deconvolution, copy of current 
document  is made with deconvoluted peak list.

Deconvolution tool.

• Mass type - mass type to be used for charge re-calculation.

• Grouping window - default window to group peaks with unknown FWHM value.

• Group peaks - apply grouping to neighboring peaks.

• Force grouping window - use default window even if FWHM value is known.

➡ To open deconvolution tool:
Press  button from the main toolbar, then press  button from the panel toolbar or choose 
Processing → Deconvolution from the main menu.

➡ To deconvolute data:
Specify all the parameters and press Apply button. New document with deconvoluted peak list will 
be generated.

Use Spectrum Generator tool to make artificial mass spectrum from deconvoluted peak list.

Use Label Envelope tool to manually label peak clusters which are hard to process automatically.

Please note that peaks’ charge state must be set prior to deconvolution.  Use either automatic peak 
picking followed by deisotoping or manually set charge in Peak Editor.

7.8. Batch Processing

In order to save time, you can apply same processing steps to multiple documents at once using Batch 
Processing tool.
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Batch Processing tool.

➡ To open batch processing tool:
Press  button from the main toolbar, then press  button from the panel toolbar or choose 
Processing → Batch Processing from the main menu.

➡ To apply processing to multiple documents:
Select documents to be processed, check all the processing steps and press Apply button.

To prevent double baseline correction, double smoothing or double deisotoping, these options are 
disabled if corresponding processing step is checked in Peak Picking panel. However, please note 
that for Peak Picking tool, baseline correction and smoothing is applied only temporarily.

7.9. Utilities

Swap Data

For ASCII XY  and some mzXML documents mMass is unable to determine whether document contains 
line spectrum points or just centroides of peaks and chooses line spectrum as default.  If this decision isn’t 
correct you can swap the data between line spectrum and peak list.

➡ To swap data between spectrum and peak list:
Choose Processing → Swap Data from the main menu.
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8. Calibration
In order to re-calibrate you data mMass enables two principal approaches - standard calibration and 
statistical calibration. In the case of standard calibration any reference list must be selected first and 
reference values must be assigned to measured peaks. Reference values are assigned automatically using 
Tolerance value. You can use either Linear or Quadratic fitting to calculate calibration constants. In 
general, linear fitting is much safer if you want to re-calibrate an m/z range outside of your assigned 
references. Always see a calibration plot before recalculating your data.

Statistical calibration, sometimes called “self-calibration” is a special method for peptide mass spectra 
only. It does not need any external reference points since it is based on the fact that monoisotopic masses 
of peptides are distributed in a very regular way. Decimal fraction of the peptide mass can be calculated 
with sufficient accuracy just by multiplying their integral part by factor 1.00048. For this method, every 
peak above 700 m/z limit is recalculated and used as reference mass.

It is sometimes good to use other known peaks as internal calibration standards. Once you have the 
theoretical masses defined within your annotations or sequence matches, you can use them to re-calibrate 
your data.

Calibration tool.

Calibration Error Plot.

➡ To show calibration tool:
Press  button from the main toolbar or choose Processing → Calibration from the main menu.

➡ To show error plot:
Press  button from the panel toolbar.
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➡ To assign reference masses:
Specify Tolerance value and Units and press Assign button.

➡ To exclude assigned reference from calculation:
Double-click on the reference in the list. Corresponding line turns grey and italic.

➡ To highlight reference mass in spectrum viewer:
Click on the reference in the list and spectrum moves to theoretical m/z value. Small red arrow 
shows up on m/z axis of the spectrum. Current zoom range remains the same.

➡ To use statistical calibration:
Check Statistical only checkbox.  Reference masses and calibration constants are automatically 
calculated from the current peak list.

➡ To define new reference list:
Choose Libraries → Reference Masses from the main menu to show up Reference Masses Library 
editor. See Libraries chapter for more information.

➡ To re-calibrate data by user annotations:
Right-click on any single annotation or the annotations root in Documents Panel and select Calibrate 
by Annotations. All the user annotations will be send to Calibration panel. Please note that only 
those annotations with specified theoretical m/z value can be used.

➡ To re-calibrate data by sequence matches:
Right-click on any single match or sequence title in Documents Panel and select Calibrate by 
Matches. All the matches will be send to Calibration panel.

➡ To apply same calibration to multiple documents:
Once the calibration is calculated you can apply it to multiple documents. Simply select another 
document in Documents Panel and press Apply Recent button.

Always check Error plot to see whether the calibration is correct.

In general, use Linear fitting if assigned references do not cover entire m/z range you’d like to 
calibrate.

Single-point calibration can be used for linear fitting.

User annotations and sequence matches are re-calibrated as well.

Please note that at least 3 reference mass points are needed for quadratic fitting.

Please note that the calibration is calculated using absolute m/z errors. Therefore shown calibration 
curve cannot be liner if you have “ppm” units selected, even if linear model is used.

Please note that statistical calibration can be used for peptides only! Any non-peptide contamination 
or modification could have disturbing effect to the calibration and should be discarded from 
calculations.
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9. Periodic Table of Elements
Periodic Table of Elements provides some basic information about the elements.  Different groups can be 
highlighted and element name, mass and isotopic pattern can be shown. For each element its detailed 
information can be seen on Wikipedia (en.wikipedia.org/wiki/Periodic_table) or The Photographic 
Periodic Table of the Elements (www.periodictable.com) using direct links.

Periodic Table of Elements.

➡ To show periodic table:
Choose Tools → Periodic Table from the main menu.

➡ To highlight group of elements:
Select the group name from the Highlight combo box.

➡ To see element name and mass:
Press the element button.

➡ To see isotopic pattern of element:
Select the element in the table and press Isotopes button. Element pattern will be shown in Mass 
Calculator tool.

➡ To see detailed information about element:
Select the element in the table and press Wikipedia button. Corresponding wiki page shows up in 
your web browser.

➡ To see element photos:
Select the element in the table and press Photos button. Corresponding photo page shows up in your 
web browser.
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10.Mass Calculator
Mass Calculator provides a tools for calculation of molecular masses of compounds,  generation of ion 
series and isotopic pattern simulation. Molecular formula can be typed manually or can be sent from 
various mMass’s tools such as Protein Digest,  Peptide Fragmentation etc. Theoretical isotopic profile can 
be easily overlaid with measured data or stored as regular document.

➡ To show mass calculator:
Press  button from the main toolbar or choose Tools → Mass Calculator from the main menu.

10.1. Formula Syntax

All known elements and their isotopes are defined within mMass’s library and can be used to define any 
compound. Use the following syntax rules to specify compound formula:

• Use common syntax to type simple formula: C16H32O2.

• Use parenthesis “()” to define groups: CH3(CH2)14COOH

• Use negative “-” values to remove atoms: CH3(CH2)14COOH(NaH-1)

• Use braces “{}” to define specific isotope of the element: C{13}16H32O2

Please note that using negative values for groups such as C16H32O2(OH)-1 does not work.

10.2. Compound Summary

Compound Summary panel provides a fast preview of the compound defined in Formula field. 
Composition, Monoisotopic and Average masses are shown.

Compound Summary.

➡ To show compound summary:
Press  button from the main toolbar or choose Tools → Mass Calculator from the main menu to 
show up Mass Calculator panel. Then press  button from the panel toolbar and write your 
compound into Formula field.

10.3. Ion Series

Using Ion Series panel you can see all the ions for the compound defined in Formula field. 
Corresponding monoisotopic and average masses are calculated with respect to polarity settings. By 
default, a proton is used as a “charging agent” but you can specify your own formula or “e” for radical 
ions.

mMass User’s Guide

© 2005–2013 Martin Strohalm  Page 51



Ion Series.

➡ To show ion series:
Press  button from the main toolbar or choose Tools → Mass Calculator from the main menu to 
show up Mass Calculator panel. Then press  button from the panel toolbar and type your 
compound into Formula field. Ions are generated automatically.

➡ To copy ion series into clipboard:
Click into the ions list and press Command+C (Ctrl+C on MS Windows and Linux).

10.4. Isotopic Pattern

Isotopic Pattern panel provides a simple tool for generating theoretical isotopic pattern from compound 
formula. Isotopes are calculated and grouped together with respect to specified peak width (FWHM).  For 
each isotope, peak shape can be modeled as either symmetrical (Gaussian) or asymmetrical (half-
Gaussian, half-Lorentzian) and final profile is calculated as a sum of all the peaks.

Theoretical isotopic profile can be overlaid with measured data and positioned precisely using FWHM, 
Intensity, Baseline and m/z Shift. You can save theoretical profile as regular document as well.

Isotopic Pattern within Mass Calculator tool.

Collapsed version of Isotopic Pattern panel.
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➡ To show isotopic pattern:
Press  button from the main toolbar or choose Tools → Mass Calculator from the main menu to 
show up Mass Calculator panel. Then press  button from the panel toolbar and type your 
compound into Formula field.

➡ To change the ion type for current isotopic patter:
Press  button from the panel toolbar and select desired ion type in the list.

➡ To overlay isotopic pattern with measured data:
Press  button from the panel toolbar and select desired ion type in the list. Theoretical pattern is 
then overlaid with measured data. Set Intensity, Baseline and Shift values to position the pattern 
precisely.

➡ To save current isotopic pattern as regular document:
Press Save button from the panel toolbar.

➡ To collapse pattern panel:
Press the small triangle on the left side of the panel toolbar.

➡ To show individual peaks:
Check Show peaks checkbox in the panel toolbar.

Use asymmetrical peak shape to model isotopic pattern of TOF instruments.

Use the same spectrum manipulation conventions in isotopic pattern window as in the main 
Spectrum Viewer.

Turn off the Peaks checkbox to speed up calculation of complex patterns with ultra-high resolution.

Use collapsed panel while overlaying theoretical profile and acquired data. This provides you more 
space to look at your data but all the positioning parameters are still available.

Please note that when overlaying theoretical profile and acquired data, offset and flipping is applied 
automatically according to selected document.
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11.Mass to Formula
Modern high-accuracy instruments allows for calculation of molecular formulae from a single measured 
mass. Mass To Formula tool generates all possible molecular formulae corresponding to given mass, 
tolerance and composition limits. To eliminate nonsense formulae, several composition rules can be 
applied and theoretical isotopic pattern can be automatically compared with measured profile. In addition, 
result can be directly searched within several public databases such as PubChem, METLIN, ChemSpider, 
HMDB or Lipid MAPS.

Mass to Formula tool.

• Mo. mass - m/z value of ion or neutral compound to be calculated.

• Charge - current charge and ionization specie of an ion.

• Tolerance - mass tolerance value and units for calculated compounds.

• Minimal formula - minimal composition for calculated compounds.

• Maximal formula - maximal composition for calculated compounds.

• Composition rules - rules to be applied to filter nonsense compounds.

• Check isotopic patter - calculate similarity value (in %) between theoretical and measured profile.

You can specify limits for each element allowed for the resulting formulae, however, limits for the 
elements like C, H, N and O are calculated automatically (if not specified) using the following rules.

C < 40, H < 80, N < 20, O <20 if neutral mass <500
C < 80, H < 130, N < 30, O <30 if neutral mass 500 - 1000

C < 160, H < 250, N < 40, O <70 if neutral mass 1000 - 2000
C < 180, H < 300, N < 60, O <90 if neutral mass >2000

In order to show relevant compositions only, following rules can be applied:

• H/C rule - if checked, only the compounds with following  hydrogen/carbon ratio are shown:

0.1 ≤ H/C ≤ 3.0

• NOPS/C rule - if checked, only the compounds with following heteroatom/carbon ratios are shown:

N/C < 4, O/C < 3, P/C < 2 and S/C < 3

• NOPS rule - if checked, only the compounds with following heteroatom counts are shown:
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N < 10, O < 20, P < 4, S < 3 if NOPS each > 1
N < 11, O < 21, P < 6 if NOP each > 3
O < 14, P < 3, S < 3 if OPS each > 1
N < 3, P < 3, S < 4 if NPS each > 1

N < 19, O < 14, S < 8 if NOS each > 6

• RDBE rule - if checked, only the compounds with following ring and double-bond equivalent for 
neutral compound are shown:

-1 ≤ RDBE ≤ 40

• Integer RDBE rule - if checked, only the compounds with integer value of ring and double-bond 
equivalent for neutral compound are shown. It corresponds to the neutral compounds with even 
electron configuration.

➡ To generate formula from mass:
Press  button from the main toolbar or choose Tools → Mass to Formula from the main menu to 
show up Mass to Formula panel. Specify all the parameters and press Generate button.

➡ To highlight compound mass in spectrum viewer:
Click on the compound and spectrum moves to theoretical m/z value. Small red arrow shows up on 
m/z axis of the spectrum. Current zoom range remains the same.

➡ To show isotopic pattern of compound:
Double-click on the compound to show up Mass Calculator panel. Compound formula appears in 
Formula field and corresponding ion type is selected automatically. See Mass Calculator chapter for 
more information.

➡ To search compound in public databases:
Right-click on the compound and choose the database to use. HTML page will be generated and sent 
to specified server. Results show up in your default web browser.

➡ To copy compounds into clipboard:
Click into the list and press Command+C (Ctrl+C on MS Windows and Linux) or use pop-up menu.

See Kind T. at al. 2007 BMC Bioniformatics for more information about the composition rules.

Please note that there is an internal limit of 1000 compounds to be calculated at most.

Please note that isotopic pattern can be compared with profile data only.
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12.Mass Defect Plot
Mass Defect Plot serves as a simple tool to visualize peaks in selected document based on their 
Fractional Mass or various types of mass defect.  In a generated plot, similar compounds tend to group 
into clusters. Standard Mass Defect is defined as the difference between a compound’s or peaks’s exact 
mass and its nominal mass. Here the nominal mass can be calculated as Round,  Floor (round down) or 
Ceil (round up). Similarly, the Relative Mass Defect is caclulated by dividing the standard mass defect by 
current m/z of the peak and multiplied by 1e6. Kendrick Mass Defect can be utilized to group all the 
compounds differing just in the number of CH2 groups (or any user-specified formula).

Mass Defect Plot tool.

• MD type - mass defect type to show.

• Nominal mass - function to use for nominal mass calculation (exact mass rounding).

• Kendrick formula - molecular formula to use for Kendrick mass defect.

• Int. threshold - hides peaks below specified relative intensity limit.

• Remove isotopes - removes assigned isotopes (deisotoping step needs to be applied before).

• Ignore charge - do not recalculate multiply charged items and use acquired m/z instead.

• Highlight annotated - highlights all annotated peaks and sequence matches.

• Show all documents - overlay all visible documents in single plot.

➡ To generate mass defect plot:
Press  button from the main toolbar or choose Tools → Mass Defect Plot from the main menu to 
show up Mass Defect Plot panel. Specify all the parameters and press Plot button.

➡ To highlight annotated peaks:
In the panel toolbar check the Highlight annotated checkbox. All the annotated peaks show in red.

➡ To show all visible documents:
In the panel toolbar check the Show all documents checkbox. All the opened and visible documents 
will be show.

➡ To highlight mass in the spectrum viewer:
Left-click within the plot area to show selected mass in the main spectrum viewer. Spectrum moves 
to selected position and highlights it using a small red arrow on x-axis.

See Sleno L. 2012 J Mass Spectrom for more information about the mass defect in MS.
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13.Sequence Tools
mMass provides an internal Sequence Editor,  which can be used to make any protein or peptide sequence 
available for other tools. Any modification can be applied either as fixed or variable. Protein Digest tool 
can be used to generate a list of peptides resulting from in silico enzymatic or chemical digestion of 
specified protein sequence. Similarly, Peptide Fragmentation tool generates a list of common peptide 
fragments. In both cases,  all possible combinations of variable modifications are calculated and results 
can be easily compared with measured data. In addition,  sequence can be searched for a sub-peptide mass 
by Mass Search tool to identify any non-specific or semi-specific cleavages.

➡ To add new sequence:
Press  button from the Documents Panel bottom toolbar and select New Sequence or choose 
Sequence → New from the main menu. Sequence Editor shows up. Type your sequence manually or 
use copy/paste.

➡ To import sequence:
Choose Sequence → Import from the main menu and select your sequence file. If more than one 
sequence are available in the file, a selection dialog shows up. Select one or more sequence and 
press Import button. mMass and FASTA documents are currently supported.

➡ To edit sequence:
Double-click on the sequence title in Documents Panel and Sequence Editor shows up.

➡ To delete sequence:
Click on the sequence title in Documents Panel and press Command+Backspace or Delete, or press 

 button from the Documents Panel bottom toolbar and choose Delete Sequence.

➡ To generate isotopic pattern of sequence:
In Sequence Editor press Pattern button.

If you are using some of the sequences frequently, you can make a personal sequence library by 
saving the sequences into a single mMass’s document.

Please note that only the valid sequences are shown in the import dialog.

13.1. Sequence Editor

Internal Sequence Editor provides a tool to define protein or peptide sequence to be available for other 
tools. While typical protein sequence consists of regular proteinogenic amino acids, with some optional 
modifications, this is not the case for amount of naturally occurring peptides, where various building 
blocks (monomers) are used as well. For this reason, mMass provides two different sequence editors, 
which can be switched by the Sequence type combo box. In addition, sequence structure can be set as 
linear or cyclic.

Please note that some tools are not available for custom-type or cyclic sequences.

Standard Sequence Editor

Using the standard sequence editor, a sequence can be manually typed, pasted from clipboard or imported 
from any mMass or FASTA document. Every input is automatically checked to contain regular amino 
acids only. If any modification is set using Modifications panel, modified amino acids are shown in red.
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Standard Sequence Editor.

If a sequence is pasted from the clipboard all white spaces and numbers are removed automatically. 
This can be very useful if you copy/paste a sequence from web sites.

Custom-Type Sequence Editor

Using the custom-type sequence editor, any non-standard peptide sequence consisting of up to 20 user-
definable monomers can be created. Sequence monomers can be manually typed into corresponding fields 
or dropped from Monomer Library panel.

Custom Sequence Editor

➡ To show available monomers:
Press  button from the Sequence Editor toolbar to show up Monomer Library panel.

➡ To compose custom sequence:
Drag and drop any monomer from Monomer Library panel or type particular abbreviation manually.

➡ To add / edit monomer definition:
Choose Libraries → Monomers from the main menu to show up Monomers Library editor. See 
Libraries chapter for more information.

Use the search field of Monomer Library panel to quickly find a monomer you are looking for.
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Please note that each sequence is automatically checked to contain defined monomers only. If any 
error or gap is found in the sequence, the remaining part is ignored.

13.2. Modifications

In Sequence Modifications panel any post-translational modification can be set to sequence terminus, a 
single amino acid or to selected type. Beside a position, for each modification you can specify whether it 
should be Fixed or Variable and all possible variants are then calculated in the sequence related tools. In 
order to avoid permanent assignment of the same modification set you can define your own presets and 
use it frequently.

Sequence Modifications.

• Show specific modifications only - show modifications specific for selected amino acid.

• Position - amino acid type and position.

• Modification - modification name and type.

➡ To add modification:
Press  button from the Sequence panel toolbar to show up Sequence Modifications. Select amino 
acid type, position, modification and modification type and press Add button.

➡ To remove modification:
Press  button from the Sequence panel toolbar to show up Sequence Modifications. Select  desired 
modification in the list and press Remove button.

➡ To add / edit modification definition:
Choose Libraries → Modifications from the main menu to show up Modifications Library editor.  See 
Libraries chapter for more information.

➡ To save current global modifications as presets:
Press  button from the panel toolbar and choose Save as Presets. In the dialog type the presets 
name and press Save button.

➡ To use saved presets:
Press  button from the panel toolbar and choose any of your presets from the pup-up menu.

➡ To delete saved presets:
Choose Libraries → Presets from the main menu to show up Presets Library editor. Choose the 
presets you’d like to delete and press Delete button.

➡ To rename saved presets:
Choose Libraries → Presets from the main menu to show up Presets Library editor. Choose the 
presets you’d like to rename, type the new name and press Rename button.
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Please note that multiple modifications on a single residue are not allowed.

Please note that terminal modification are removed upon cyclization.

Please note that global and terminal modifications can only be stored in presets.

Please note that modifications are not available for custom-type sequences.

13.3. Protein Digest

Many experiments,  involving detection of modifications, protein validation etc., apply the specific 
enzymatic digestion of a protein with a known sequence. Protein Digest panel provides a tool which can 
be used to generate a list of peptides resulting from in silico digestion of a sequence. Masses of these 
peptides can then be compared with current peak list within a specified tolerance to see any matches. In 
addition, theoretical isotopic patterns can be generated and overlaid with the data to validate matches.

Protein Digest tool.

• Mass - mass type to be used for calculations.

• Max charge - maximum charge to be calculated.

• Enzyme - enzyme to be used to simulate digestion.

• Miscl. - maximum number of enzyme miss cleavages.

• Mass range - m/z range for peptides to be calculated.

• Ignore mods - ignore modifications in cleavage site.

• Coverage - matched / theoretical sequence coverage.

➡ To digest protein:
Double-click on the sequence title in Documents Panel to show up Sequence tools and press  
button for Protein Digest tool. Specify all the parameters and press Digest button.

➡ To highlight peptide mass in spectrum viewer:
Click on the peptide and spectrum moves to theoretical m/z value. Small red arrow shows up on m/z 
axis of the spectrum. Current zoom range remains the same.
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➡ To show isotopic pattern of peptide:
Double-click on the peptide to show up Mass Calculator panel. Peptide formula appears in Formula 
field and corresponding ion type is selected. See Mass Calculator chapter for more information.

➡ To match peptides to peak list:
Generate theoretical peptides and press Match button in the panel toolbar to show up Match Peptides 
panel.  Matched peptides shows green and bold in the list.  See Data Matching chapter for more 
information.

➡ To annotate peaks by matched peptides:
Press Annotate button in the panel toolbar.  All the matched items show up in Documents Panel 
under current sequence.

➡ To copy peptide sequence into clipboard:
Right-click on any peptide and choose Copy Selected Sequence from pop-up menu.

➡ To copy peptides into clipboard:
Click into the list and press Command+C (Ctrl+C on MS Windows and Linux) or use pop-up menu.

➡ To see matched/unmatched peptides only:
Right-click into the list and select view option from pop-up menu.

➡ To add / edit enzyme definition:
Choose Libraries → Enzymes from the main menu to show up Enzymes Library editor. See Libraries 
chapter for more information.

Use theoretical sequence coverage to select the right enzyme for particular protein and mass range.

Please note that this tool is not available for custom-type and cyclic sequences.

13.4. Peptide Fragmentation

Different types of fragmentation techniques can be used for peptide sequence validation, as well as for the 
detection, localization and characterization of post-translational modifications. For these types of 
experiments, common fragments of a peptide sequence can be generated in silico using Peptide 
Fragmentation tool. Depending on a fragmentation technique used, different fragments can be generated. 
Some of the peptide fragments are theoretical only and can be removed using Remove filtered check box.

Peptide Fragmentation tool.
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• Mass - mass type to be used for calculations.

• Max charge - maximum charge to be calculated.

➡ To fragment peptide:
Double-click on the sequence title in Documents Panel to show up Sequence tools and press  
button for Peptide Fragmentation tool. Specify all the parameters and press Fragment button.

➡ To highlight fragment mass in spectrum viewer:
Click on the fragment and spectrum moves to theoretical m/z value.  Small red arrow shows up on m/
z axis of the spectrum. Current zoom range remains the same.

➡ To show isotopic pattern of fragment:
Double-click on the fragment to show up Mass Calculator panel. Fragment formula appears in 
Formula field and corresponding ion type is selected.  See Mass Calculator chapter for more 
information.

➡ To match fragments to peak list:
Generate theoretical fragments and press Match button in the panel toolbar to show up Match 
Fragments panel. Matched fragments shows green and bold in the list. See Data Matching chapter 
for more information.

➡ To annotate peaks by matched fragments:
Press Annotate button in the panel toolbar.  All the matched items show up in Documents Panel 
under current sequence.

➡ To copy fragments into clipboard:
Click into the list and press Command+C (Ctrl+C on MS Windows and Linux) or use pop-up menu.

➡ To see matched/unmatched fragments only:
Right-click into the list and select view option from pop-up menu.

➡ To save fragments settings as presets:
Press  button from the panel toolbar and choose Save as Presets. In the dialog type the presets 
name and press Save button.

➡ To use saved presets:
Press  button from the panel toolbar and choose any of your presets from the pup-up menu.

➡ To delete saved presets:
Choose Libraries → Presets from the main menu to show up Presets Library editor. Choose the 
presets you’d like to delete and press Delete button.

➡ To rename saved presets:
Choose Libraries → Presets from the main menu to show up Presets Library editor. Choose the 
presets you’d like to rename, type the new name and press Rename button.

To decrease number of false-positive matches, be sure to calculate only the relevant fragmentation 
pathways for particular fragmentation technique used.

13.5. Data Matching

Both, theoretical peptides and fragments lists can be compared with the peak list of current document by 
pressing Match button in corresponding tool.  If some of the peptides or fragments are matched 
successfully you can use them for annotations or data recalibration.
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Match tool.

Match summary.

• Tolerance - mass tolerance for data matching.

• Da, ppm - units for tolerance value.

• Ignore charge - ignore peak charge while data matching.

• Annotated - don’t use peaks with user’s annotation.

• Matched - don’t use peaks matched to sequence peptide or fragment.

• Unselected - use only peaks selected in the Peaklist Panel.

• Isotopes - don’t use isotopes.

• Unknown - don’t use peaks with no isotope number or charge assigned.

➡ To match peptides to peak list:
Generate theoretical peptides in Protein Digest tool and press Match button in the panel toolbar to 
show up Match Peptides panel. Specify the parameters and press Match button.

➡ To match fragments to peak list:
Generate theoretical fragments in Peptide Fragmentation tool and press Match button in the panel 
toolbar to show up Match Fragments panel. Specify the parameters and press Match button.

➡ To ignore peak charge and use only m/z value while data matching:
Check Ignore charge checkbox.

➡ To re-calibrate data using matches:
Press Calibrate button in the panel toolbar to send matched items into Calibration tool. See 
Calibration chapter for more information.

Use the same spectrum manipulation conventions in the error plot as in the main Spectrum Viewer.
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13.6. Mass Search

Using sequence Mass Search tool you can search a sequence for any peptide of specified m/z. This tool 
can be very useful for identification of the peaks resulting from non-specific or semi-specific cleavage of 
a protein.

Mass Search tool.

• Mass - peptide mass to be searched.

• Mo, Av - mass type to be searched.

• Max charge - maximum charge to be calculated for peptides.

• Enzyme - enzyme to use for peptide “caps” (e.g. H and OH) and semi-specificity.

• Tolerance - mass tolerance for searching.

• Da, ppm - units for tolerance value.

• Semi-specific enzyme - only the peptides resulted from partially specific digest are searched 
(otherwise the non-specific peptides are searched).

➡ To search sequence:
Double-click on the sequence title in Documents Panel to show up Sequence tools and press  
button for Mass Search tool.  Specify all the parameters and press Search button. List of matched 
peptides will be shown.

➡ To highlight peptide mass in spectrum viewer:
Click on the peptide and spectrum moves to theoretical m/z value. Small red arrow shows up on m/z 
axis of the spectrum. Current zoom range remains the same.

➡ To show isotopic pattern of peptide:
Double-click on the peptide to show up Mass Calculator panel. Peptide formula appears in Formula 
field and corresponding ion type is selected. See Mass Calculator chapter for more information.

➡ To copy peptide sequence into clipboard:
Right-click on any peptide and choose Copy Selected Sequence from pop-up menu.

➡ To copy peptides into clipboard:
Click into the list and press Command+C (Ctrl+C on MS Windows and Linux) or use pop-up menu.
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14.Mass Filter
In many mass spectra, common contaminant masses are observed and can have a negative effect on data 
interpretation. Keratin and trypsin autolysis peptides are the most know examples in protein identification 
experiments. Using Mass Filter tool, such contaminants can be easily annotated or removed completely 
from a peak list. In addition, matched peaks can be used as an internal standard for data re-calibration.

Mass Filter tool.

Match References tool.

• Tolerance - mass tolerance for data matching.

• Da, ppm - units for tolerance value.

• Ignore charge - ignore peak charge while data matching.

• Annotated - don’t use peaks with user’s annotation.

• Matched - don’t use peaks matched to sequence peptide or fragment.

• Unselected - use only peaks selected in the Peaklist Panel.

• Isotopes - don’t use isotopes.

• Unknown - don’t use peaks with no isotope number or charge assigned.

➡ To filter contaminant masses:
Press  button from the main toolbar or choose Tools → Mass Filter from the main menu.. Select 
References list name and press Match button to show up Match References tool.

➡ To annotate matched peaks:
When the mass list is matched to your data press Annotate button in the Mass Filter panel toolbar. 
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All the matched items show up in Documents Panel under Annotations.  If you want to exclude any 
matched item just double-click the item in Mass Filter list.

➡ To remove matched peaks:
When the mass list is matched to your data press Remove button in the Mass Filter panel toolbar. All 
the matched peak will be removed from  the peak list. If you want to exclude any matched item just 
double-click the item in Mass Filter list.

➡ To re-calibrate data using matches:
Press Calibrate button in the Match References panel toolbar to send matched items into Calibration 
tool. See Calibration chapter for more information.

➡ To define a new list of reference masses:
Choose Libraries → Reference Masses from the main menu to show up Reference Masses Library 
editor. See Libraries chapter for more information.

Use the same spectrum manipulation conventions in the error plot as in the main Spectrum Viewer.

See match summary panel for more information about current match.

Please note that since the reference masses don’t have the charge value defined, the Ignore charge 
switch doesn’t have any effect in this tool.
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15.Compounds Search
Using Compounds Search tool you can search for any user-specified compound or even a list of 
compounds in a peak list. Every compound is specified in mMass’s library as molecular formula, title and 
description, therefore both monoisotopic or average masses can be search with any charge. In addition 
common adducts can be searched automatically as well. All the matched peaks can be annotated and then 
shown or printed within analysis report.

Compounds Search tool.

• Compounds - compounds list to be searched.

• Formula - compound formula to be searched.

• Mass - mass type to be searched.

• Max charge - maximum charge to be calculated.

• M* - calculate radical ions.

• Adducts - type of adduct to be searched.

➡ To search for list of compounds:
Press  button from the main toolbar or choose Tools → Compounds Search from the main menu 
and select  tool in the panel toolbar. Select Compounds list name, set the parameters and press 
Generate button. Then press Match button to show up Match Compounds tool.

➡ To search for specified formula:
Press  button from the main toolbar or choose Tools → Compounds Search from the main menu 
and select  tool in the panel toolbar. Type compound Formula,  set the parameters and press 
Generate button. Then press Match button to show up Match Compounds tool. See Mass Calculator 
chapter for more information about formula syntax.

➡ To highlight compound mass in spectrum viewer:
Click on the compound and spectrum moves to theoretical m/z value. Small red arrow shows up on 
m/z axis of the spectrum. Current zoom range remains the same.

➡ To show isotopic pattern of compound:
Double-click on the compound to show up Mass Calculator panel. Compound formula appears in 
Formula field and corresponding ion type is selected automatically. See Mass Calculator chapter for 
more information.

➡ To copy compounds into clipboard:
Click into the list and press Command+C (Ctrl+C on MS Windows and Linux) or use pop-up menu.
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➡ To see matched/unmatched compounds only:
Right-click into the list and select view option from pop-up menu.

➡ To define a new list of compounds:
Choose Libraries → Compounds from the main menu to show up Compounds Library editor.  See 
Libraries chapter for more information.

➡ To match compounds to peak list:
Generate theoretical compounds and press Match button in the panel toolbar to show up Match 
Compounds panel.

Match Compounds tool.

Match Compounds summary.

• Tolerance - mass tolerance for data matching.

• Da, ppm - units for tolerance value.

• Ignore charge - ignore peak charge while data matching.

• Annotated - don’t use peaks with user’s annotation.

• Matched - don’t use peaks matched to sequence peptide or fragment.

• Unselected - use only peaks selected in the Peaklist Panel.

• Isotopes - don’t use isotopes.

• Unknown - don’t use peaks with no isotope number or charge assigned.

➡ To annotate peaks by matched compounds:
Press Annotate button in panel toolbar. All the matched items show up in Documents Panel under 
Annotations.

➡ To ignore peak charge while data matching:
Check Ignore charge checkbox.
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➡ To re-calibrate data using matches:
Press Calibrate button in the panel toolbar to send matched items into Calibration tool. See 
Calibration chapter for more information.

Use the same spectrum manipulation conventions in the error plot as in the main Spectrum Viewer.

See match summary panel for more information about current match.
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16.Peak Differences
Interpretation of mass spectra typically involves a seemingly never-ending check of the differences 
between all peaks in a spectrum. However, Peak Differences tool is able to simply generate a table of all 
the differences between the peaks in the peak list. This table can then be used to automatically compare, 
within a specified tolerance,  each difference with the respective masses of all amino acids, calculated 
dipeptides or specified m/z value. Peak Differences tool therefore provides a useful utility for de novo 
peptide sequencing or PTM search.

matches for selected differencetable of differencespeak list

Peak Differences tool.

• Difference - user defined m/z difference to searched.

• Amino acids - all available amino acids will be searched.

• Dipeptides - all calculated dipeptides will be searched.

• Mass - mass type to be used for amino acids and dipeptides calculation.

• Tolerance - mass tolerance for searching.

• Hide umatched - if checked, only the matched peaks will be shown.

➡ To show peak differences tool:
Press  button from the main toolbar or choose Tools → Peak Differences from the main menu.

➡ To search:
Specify all the parameters and press Search button from the panel toolbar. Click on any highlighted 
differences to see corresponding matches.

If the specified mass is matched, corresponding difference turns green. If at least one amino acid is 
matched, corresponding difference turns dark blue. If at least one dipeptide is matched, 
corresponding difference turns light blue.
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17.Compare Peak Lists
Similarly as the Peak Differences tool, the Compare Peak Lists tool can easily be utilized to compare 
peak lists or annotations between multiple documents.  Using this tool, one of the most typical and 
annoying manual task can be automatically performed within a few clicks.  Once the tool is shown, all 
documents are loaded and marked by its own spectrum color and can be compared within the specified 
mass tolerance or even using intensity ratio threshold. For each peak identified in a different document, 
corresponding document color is highlighted next to the m/z value.  By selecting any m/z value in the peak 
lists table, all the matched peaks are shown followed by error and intensity ratios (a - selected peak, b - 
matched peak). In addition to individual peak lists, separate table for combined peak list is also available.

matches for selected peakcombined peak listindividual peak lists

Compare Peak Lists tool.

• Compare - data type to be compared.

• Tolerance - mass tolerance for comparison.

• Da, ppm - units for tolerance value.

• Ignore charge - ignore peak charge while comparing peaks.

➡ To show compare peak lists tool:
Press  button from the main toolbar or choose Tools → Compare Peak Lists from the main menu.

➡ To compare:
Specify all the parameters and press Compare button from the panel toolbar. Click on any m/z value 
in the peak lists table to see corresponding matches.

➡ To remove peak list temporarily:
Disable document by clicking the corresponding document bullet in the main Documents Panel.

➡ To copy tables into clipboard:
Click into the table you’d like to copy and press Command+C (Ctrl+C on MS Windows and Linux).

mMass User’s Guide

© 2005–2013 Martin Strohalm  Page 71



18.Spectrum Generator
In various cases, such as identification of peak overlaps or validation of different algorithms, it might be 
useful to generate an artificial mass spectrum to compare with acquired data or to test an algorithm 
capability. Using Spectrum Generator tool you can model each peak of the peak list of selected document 
as either symmetric (Gaussian) or asymmetric (half-Gaussian, half-Lorentzian) curve with corresponding 
intensity, specified width (FWHM) and number of points per peak. All the peaks are combined together to 
make final profile spectrum, which can be overlaid with Spectrum Viewer content or saved to selected 
document. To add more realistic look you can apply some random noise of specified width.

Spectrum Generator tool.

• Peak shape - symmetric (Gaussian) or asymmetric (half-Gaussian, half-Lorentzian) peak shape.

• Default FWHM - default FWHM value used if peak’s own value is unknown.

• Force - use default FWHM value even if peak’s own value is known.

• Points/peak - approximated number of points to draw each peak.

• Noise width - width of randomly generated noise.

• Show peaks - show individual peak shapes in generated spectrum.

• Show overlay - show generated profile in the main spectrum viewer.

• Flip overlay - show overlaid profile flipped in the main spectrum viewer.

• Generate - generate spectrum according to current parameters.

• Apply - apply generated profile spectrum to current document.

➡ To model artificial mass spectrum:
Make a new blank document by choosing File → New from the main menu. Press  button from 
the Peaklist Panel bottom toolbar to show peak editor and define a peak list you’d like to model. 
Press  button from the main toolbar or choose Tools → Spectrum Generator from the main menu 
to show Spectrum Generator tool. Specify all the parameters and press Generate button.

➡ To save generated spectrum to current document
Generate artificial spectrum and press Apply button. Current document’s spectrum will be replaced 
by the newly generated. This operation can be undone.

Use asymmetrical peak shape to model TOF instrument spectra.
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19.Envelope Fit
Envelope Fit serves as a simple tool to determine incorporation of heavy atoms into a molecule. 
Hydrogen/deuterium exchange experiment might be a typical example.  In general,  it calculates all the 
possible isotopic patterns for specified Formula and Exchange loss/gain formulae, and uses their linear 
combination and least-square fitting to fit modeled patterns to acquired data. Percentage of each 
individual state as well as average incorporation are shown as a result.

Envelope Fit tool.

• Formula - basic formula to use for modeling.

• Charge - charge state of the peak to fit to.

• Exchange - atoms to be exchanged (loss vs. gain).

• Range - minimum and maximum number of exchanged atoms.

• Fit to - acquired data type to fit to.

• Default FWHM - default FWHM value used if peak’s own value is unknown.

• Force - use default FWHM value even if peak’s own value is known.

• Rel. threshold - relative intensity threshold for peaks involved (to basepeak of relevant mass range).

• Auto align - automatically align acquired data with modeled envelope.

• Average X - calculated average number of exchanged atoms.

➡ To show envelope fit tool:
Press  button from the main toolbar or choose Tools → Envelope Fit from the main menu.

➡ To calculate peptide sequence deuteration:
Use Sequence Editor to define a sequence. Right-click on the sequence title in Documents Panel and 
choose Send to Envelope Fit...  to send data to Envelope Fit panel. Specify all the parameters and 
press Calculate button. (Use “H” and “H{2}” for the Exchange values.)

Sequences, sequence matches and annotations can be sent to Envelope Fit by right-clicking the item 
in Documents Panel and choosing Send to Envelope Fit... Similarly, any generated peptide can be 
used as well from Protein Digest or Mass Search panels.

Use relevant exchange Range to speed up calculation or discard unwanted peaks.
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Use Rel. threshold or make your own peak list then Fit to Peak list to discard unwanted peaks.

If a sequence object is sent to Envelope Fit tool and H/H{2} are set for exchange, corresponding 
deuteration range is calculated automatically.

Auto align feature should be turned on in most cases. It is used to ensure that corresponding peak 
maxima are used for each isotope fitting.

Be sure to have a correct charge specified!
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20.Mascot Search
mMass provides an interface that allows data to be directly sent to the main tools available on Mascot 
website (http://www.matrixscience.com); Peptide Mass Fingerprint, Sequence Query and MS/MS Ion 
Search. When Search button is pressed, temporary HTML page is generated containing all the parameters 
and using JavaScript,  the page is automatically sent to selected server. Please see the Mascot website for 
more information about the tools and the form fields.

Peptide Mass Fingerprint search tool.

➡ To show peptide mass fingerprint tool:
Press  button from the main toolbar to show Mascot tools and press  button from the panel 
toolbar or choose Tools → Mascot Peptide Mass Fingerprint from the main menu.

➡ To show MS/MS ion search tool:
Press  button from the main toolbar to show Mascot tools and press  button from the panel 
toolbar or choose Tools → Mascot MS/MS Ion Search from the main menu.

➡ To show sequence query tool:
Press  button from the main toolbar to show Mascot tools and press  button from the panel 
toolbar or choose Tools → Mascot Sequence Query from the main menu.

➡ To change server:
Select the Server in the panel toolbar.

➡ To send data to server:
Specify all the parameters and press Send button in the panel toolbar. HTML page will be generated 
and sent to specified server. Results show up in your default web browser.

➡ To define new server:
Choose Libraries → Mascot Servers from the main menu to show up Mascot Servers Library editor. 
See Libraries chapter for more information.
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➡ To specify peak list or query:
Press  from the panel toolbar and type your query manually or peak list filters.

Query / Peak List.

• Annotated - remove peaks with user’s annotation.

• Matched - remove peaks matched to sequence peptide or fragment.

• Unselected - use only peaks selected in the Peaklist Panel.

• Isotopes - remove isotopes.

• Unknown - remove peaks with no isotope number or charge assigned.

See http://www.matrixscience.com website for more information about Mascot tools and form 
parameters.

Please note that while changing server, most of the form fields changed as well. Check if the form is 
filled correctly.
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21.ProFound Search
mMass provides an interface that allows data to be directly sent to ProFound search tool available on a 
website of Professor Brian T. Chait group (http://prowl.rockefeller.edu). When Search button is pressed, 
temporary HTML page is generated containing all the parameters and using JavaScript,  the page is 
automatically sent to ProFound server. Please see the ProFound website for more information about the 
tool and the form fields.

ProFound search tool.

➡ To show ProFound tool:
Press  button from the main toolbar or choose Tools → ProFound from the main menu.

➡ To send data to server:
Specify all the parameters and press Send button in the panel toolbar. HTML page will be generated 
and sent to ProFound server. Results show up in your default web browser.

➡ To specify peak list:
Press  from the panel toolbar and use peak list filters.

See http://prowl.rockefeller.edu website for more information about ProFound tool and form 
parameters.
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22.Protein Prospector Search
mMass provides a simplified interface that allows data to be directly sent to the main tools available on 
Protein Prospector website (http://prospector.ucsf.edu); MS-Fit and MS-Tag.  When Search button is 
pressed, temporary HTML page is generated containing all the parameters and using JavaScript,  the page 
is automatically sent to Protein Prospector server. Please see the Protein Prospector website for more 
information about the tools and the form fields.

MS-Fit search tool.

➡ To show MS-Fit tool:
Choose Tools → Protein Prospector MS-Fit from the main menu.

➡ To show MS-Tag tool:
Choose Tools → Protein Prospector MS-Tag from the main menu.

➡ To send data to server:
Specify all the parameters and press Send button in the panel toolbar. HTML page will be generated 
and sent to Protein Prospector server. Results show up in your default web browser.

➡ To specify peak list:
Press  from the panel toolbar and use peak list filters.

See http://prospector.ucsf.edu website for more information about ProteinProspector tools and form 
parameters.
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23.Libraries
All mMass’s libraries and configuration files are located within a single configuration folder having 
different locations, depending on your platform. On Mac OS X, all configuration files can be found under 
“~/Library/Application Support/mMass/”. On MS Windows and Linux systems, all configuration files 
can be found under “configs” folder, located directly under the mMass’s main folder.  All files are in 
XML-based formats and can be easily edited manually, however, it is strongly recommended to use 
dedicated mMass’s tools.

23.1. Compounds

Compounds Library editor.

• Name - unique compound name.

• Description - brief description.

• Formula - compound formula

• Mo. mass - resulting monoisotopic mass.

• Av. mass - resulting average mass.

➡ To show compounds library editor:
Choose Libraries → Compounds from the main menu.

➡ To import compounds lists:
Open Compounds Library editor and press Import button on top of the panel. Select your 
compounds library and press Open button. Select compounds lists you’d like to import and press 
Import button. See above for location of all the libraries on your system.

➡ To add new compounds list:
Open Compounds Library editor and press New button on top of the panel.  Type the name and press 
OK button.

➡ To rename compounds list:
Open Compounds Library editor,  select the list you’d like to rename and press Rename button on top 
of the panel. Type the name and press OK button.
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➡ To delete compounds list:
Open Compounds Library editor,  select the list you’d like to delete and press Delete button on top of 
the panel.

➡ To add compound:
Open Compounds Library editor and select the list for the compound. Specify all the compound 
parameters and press Add button down on the panel.

➡ To edit compound:
Open Compounds Library editor and select the list containing the compound you’d like to edit. 
Change the compound parameters and press Add button down on the panel.

➡ To rename compounds:
Open Compounds Library editor and select the list containing the compound you’d like to rename. 
Change the Name and press Add button. New compound will be added and the old one can be 
deleted.

➡ To delete compound:
Open Compounds Library editor, select the list containing the compound you’d like to delete and 
press Delete button down on the panel.

See Mass Calculator chapter for more information about formula syntax.

Monoisotopic and average masses are calculated automatically as you type the formula.

Please note that the group name must be unique for each group.

Please note that the compound name must be unique for each compound.

23.2. Modifications

Modifications Library editor.
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• Name - unique modification name.

• Description - brief description.

• Amino specifity - amino acids which can be modified.

• Term specifity - sequence terminus which can be modified.

• Gain formula - formula to be added to a sequence.

• Loss formula - formula to be removed from a sequence. 

• Mo. mass - resulting monoisotopic mass.

• Av. mass - resulting average mass.

➡ To show modification library editor:
Choose Libraries → Modifications from the main menu.

➡ To add modification:
Open Modifications Library editor, specify all the modification parameters and press Add button.

➡ To edit modification:
Open Modifications Library editor, select the modification you’d like to edit, change the parameters 
and press Add button. If the Name remains the same you will be asked to Replace modification 
definition.

➡ To rename modification:
Open Modifications Library editor, select the modification you’d like to rename, change the Name 
and press Add button. New modification will be added and the old one can be deleted.

➡ To delete modification:
Open Modifications Library editor, select the modification you’d like to delete and press Delete 
button. It is not possible to delete modification which is used in one of the opened documents.

See Mass Calculator chapter for more information about formula syntax.

Monoisotopic and average masses are calculated automatically as you type the formula.

If you open a document with undefined modification this modification is added into your library 
automatically, however, the Amino specifity is set to ACDEFGHIKLMNPQRSTVWY.

Please note that the modification name must be unique for each modification.
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23.3. Monomers

Monomers Library editor.

• Search - search tool.

• Abbr. - monomer unique abbreviation.

• Name - monomer name.

• Category - monomer category.

• Formula - monomer residual molecular formula (without water). 

• Mo. mass - calculated monoisotopic mass.

• Av. mass - calculated average mass.

• Mo. loss mass - calculated monoisotopic mass of selected neutral loss.

• Loss - molecular formula of possible neutral loss.

➡ To show monomer library editor:
Choose Libraries → Monomers from the main menu.

➡ To add monomer:
Open Monomers Library editor, specify all the monomer parameters and press Add button.

➡ To edit monomer:
Open Monomers Library editor, select the monomer you’d like to edit, change the parameters and 
press Add button. If the Abbr. remains the same you will be asked to Replace monomer definition.

➡ To delete monomer:
Open Monomers Library editor, select the monomer you’d like to delete and press Delete button. It 
is not possible to delete monomer which is currently used in one of the opened documents.

See Mass Calculator chapter for more information about formula syntax.

Monoisotopic and average masses are calculated automatically as you type the formula.
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If you open a document with undefined monomer this monomer is added into your library 
automatically, however, only the Abbr and Formula parameters are set.

Use the Search field to quickly find a monomer you are looking for.

Please note that the monomer abbreviation must be unique for each monomer.

23.4. Enzymes

Enzymes Library editor

• Name - unique enzyme name.

• Expression - enzyme regular expression.

• C-term formula - formula to be added at new C-terminus.

• N-term formula - formula to be added at new N-terminus.

• Allow modification before cut - allow modifications before cleavage site.

• Allow modification after cut - allow modifications after cleavage site.

➡ To show enzymes library editor:
Choose Libraries → Enzymes from the main menu.

➡ To add enzyme:
Open Enzymes Library editor, specify all the enzyme parameters and press Add button.

➡ To edit enzyme:
Open Enzymes Library editor, select the enzyme you’d like to edit, change the parameters and press 
Add button. If the Name remains the same you will be asked to Replace enzyme definition.

➡ To rename enzyme:
Open Enzymes Library editor, select the enzyme you’d like to rename, change the Name and press 
Add button. New enzyme will be added and the old one can be deleted.

➡ To delete enzyme:
Open Enzymes Library editor, select the enzyme you’d like to delete and press Delete button.
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The enzyme expression uses regular expression syntax where both, amino acids before and after 
cleavage must be defined. For example [KR][A-Z] for the Trypsin/P, where [KR] means that lysine 
or arginine must be before cleavage and [A-Z] means that any amino acid (i.e. character in the 
sequence) is allowed after cleavage. To block any amino acid use “^” like in the regular Trypsin 
[KR][^P].  See the http://docs.python.org/howto/regex.html#regex-howto for more information about 
regular expression syntax.

See Mass calculator chapter for more information about formula syntax.

Please note that the enzyme name must be unique for each enzyme.

23.5. Reference Masses

Reference Masses Library editor.

• Description - reference name.

• m/z - reference m/z value.

➡ To show reference masses library editor:
Choose Libraries → Reference Masses from the main menu.

➡ To import reference lists:
Open Reference Masses Library editor and press Import button on top of the panel.  Select your 
references library and press Open button. Select references lists you’d like to import and press 
Import button. See above for location of all the libraries on your system.

➡ To add new reference list:
Open Reference Masses Library editor and press New button on top of the panel. Type the name and 
press OK button.

➡ To rename reference list:
Open Reference Masses Library editor,  select the list you’d like to rename and press Rename button 
on top of the panel. Type the name and press OK button.

➡ To delete reference list:
Open Reference Masses Library editor, select the list you’d like to delete and press Delete button on 
top of the panel. Type the name and press OK button.

mMass User’s Guide

© 2005–2013 Martin Strohalm  Page 84

http://docs.python.org/howto/regex.html%23regex-howto
http://docs.python.org/howto/regex.html%23regex-howto


➡ To add reference mass:
Open Reference Masses Library editor and select appropriate reference list.  Specify all the 
parameters and press Add button down on the panel.

➡ To edit reference mass:
Open Reference Masses Library editor and select the list containing the mass you’d like to edit. 
Change the parameters and press Add button down on the panel.

➡ To rename reference mass:
Open Reference Masses Library editor and select the list containing the mass you’d like to rename. 
Change the Description and press Add button. New reference mass will be added and the old one can 
be deleted.

➡ To delete reference mass:
Open Reference Masses Library editor, select the list containing the mass you’d like to delete and 
press Delete button down on the panel.

23.6. Mascot Servers

Mascot Servers Library editor.

• Title - server title.

• Host name - IP address or domain.

• Mascot path - path to the Mascot’s main folder (“/” or “/mascot/” etc.).

• Search - path to the main search script (relative to the Mascot’s main folder).

• Results - path to the results viewer script (relative to he Mascot’s main folder).

• Export - path to the results export script (relative to he Mascot’s main folder).

• Params - path to the form parameters values (relative to he Mascot’s main folder).

➡ To show mascot servers library editor:
Choose Libraries → Mascot Servers from the main menu.

➡ To add server:
Open Mascot Servers Library editor, specify all the server parameters and press Add button.
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➡ To edit server:
Open Mascot Servers Library editor, select the server you’d like to edit, change the parameters and 
press Add button. If the Title remains the same you will be asked to Replace server definition.

➡ To rename server:
Open Mascot Servers Library editor, select the server you’d like to rename, change the Title and 
press Add button. New server will be added and the old one can be deleted.

➡ To delete server:
Open Mascot Servers Library editor, select the server you’d like to delete and press Delete button.

23.7. Presets

Presets Library editor.

• Name - presets name.

• Category - presets category.

➡ To show presets library editor:
Choose Libraries → Presets from the main menu.

➡ To rename presets:
Open Presets Library editor, select the presets you’d like to rename, change the Name and press 
Rename button.

➡ To delete presets:
Open Presets Library editor, select the presets you’d like to delete and press Delete button.
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